Jump to content
Welcome to our new Citrix community!

Admin Web - Unable to view Virtual Servers under Traffic Management --> Load Balancing after upgrade


Recommended Posts

Hello,

 

I upgrade from 11 to 13 through the normal upgrade path, and I'm no longer able to see the Virtual Servers under Traffic Management --> Load Balancing. I get the following error

 

Error in retrieving Load Balancing Virtual Server.

a[index] is undefined

 

I'm able to view the lb vserver's using the CLI. Any idea what might be causing this?

Link to comment
Share on other sites

Thank you Carl,

 

I just tried clearing the cache and it didn't make a difference.

 

I've reviewed various logs found the line in the httpaccess log and see the following line

 

"GET /nitro/v1/config/lbvserver?filter=isgslb:false,name:%2F%5E(((%5B%5Ea%5D%7Ca%5B%5Ep%5D%7Cap%5B%5Ep%5D%7Capp%5B%5E_%5D).*)%7C..%3F.%3F)%24%2F&pageno=1&pagesize=25 HTTP/1.1" 200 2213

 

I posted that line in my browser and I get a JSON formated file with all my virtual servers

 

Looks like something in the web code not processing the response correctly.

 

I tried it in IE with the clear cache and now I get

 

Error in retrieving Load Balancing Virtual Server.

Unable to set property 'effectivestate' of undefined or null reference

 

I reviewed the JSON can't see any LBVserver without effectivestate set

 

Thank you for any insights you can provide

 

 

 

Link to comment
Share on other sites

I was able to figure out the issue.

 

There was a LBVserver called __ESNS_LBVSERVER

 

__ESNS_LBVSERVER (0.0.0.0:0) - HTTP     Type: ADDRESS
        State: UP
        Last state change was at Thu Jul 18 09:13:27 2019
        Time since last state change: 23 days, 05:57:31.120
        Effective State: UP
        Client Idle Timeout: 180 sec
        Down state flush: DISABLED
        Disable Primary Vserver On Down : DISABLED
        Appflow logging: DISABLED
        Port Rewrite : DISABLED
        No. of Bound Services :  4 (Total)       4 (Active)
        Configured Method: LEASTCONNECTION
        Current Method: Round Robin, Reason: Bound service's state changed to UP        BackupMethod: ROUNDROBIN
        Mode: IP
        Persistence: NONE
        Vserver IP and Port insertion: OFF
        Push: DISABLED  Push VServer:
        Push Multi Clients: NO
        Push Label Rule: none
        L2Conn: OFF
        Skip Persistency: None
        Listen Policy: NONE
        IcmpResponse: PASSIVE
        RHIstate: PASSIVE
        New Service Startup Request Rate: 0 PER_SECOND, Increment Interval: 0
        Mac mode Retain Vlan: DISABLED
        DBS_LB: DISABLED
        Process Local: DISABLED
        Traffic Domain: 0
        TROFS Persistence honored: ENABLED
        Retain Connections on Cluster: NO

 

I searched google to determine what it's used for, but couldn't really find anything on it. except a Cisco adminguide for Citrix Netscaller. I took a backup removed the vserver .. and I was finally able to view the Virtual Servers in the GUI.

 

 

  • Like 1
Link to comment
Share on other sites

The ESNS vserver is probably associate with appflow data (as this was originally how edgesight for netscaler reported web insight data and then with Web Insight (appflow)  in InsightCenter followed by ADM, the traffic runs alongside your existing lb virtual server. You might try disabling the appflow policy association with the lb vserver either in the NS GUI or via ADM if accessible to see if that clears the issue and then re-attach it.

 

MIght be a version firmware issue that you can follow up with support or look for known issues in the release notes for this releast or later releases related to AppFlow or web insight reporting.

 

I'm also assuming you are using full admin rights and this isn't some sort of delegated admin rights limitation.  But check syslog for any other permissions issue when load gui and compare chrome vs other browser.

shell

cd /var/log/

tail -f ns.log

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...