Jump to content
Welcome to our new Citrix community!
  • 0

Xenserver 7.1.2 LTSR and APCUPS as service status fail when xen startup


Simon-Pier Voyer

Question

Hi we're changing from xenserver 6.5 to xenserver 7.1 we were using apcupsd to verify and shutdown vm and xenserver when the ups reach 10% battery left.

 

i found a newer version of apcupsd and configured every same setting.

 

i did use systemctl enable apcupsd.service  so the service start when xenserver start.

 

the problem is i get no ups status when the server starts. i have to restart apcupsd.service and then everything works.

 

any idea ?

 

maybe i can add a timer ?

 

we monitor the ups using snmp.

Link to comment

7 answers to this question

Recommended Posts

  • 0

You could add your own script to do so at the end of when all the others have been run by adding an entry to /etc/irc.local with a delay of 60 seconds, for example, with something like:

 

/bin/sleep 60

whatever- you-want-to-run ...

 

and make sure rc.local execution is enabled. Or maybe add a long sleep command in the service, itself, noting that you'd have to remember in either case to update this whenever you update/upgrade.

 

-=Tobias

  • Like 1
Link to comment
  • 0

its a brand new Xenserver installation

 

i did the same config as in Xenserver 6.5 we used system-config-securitylevel-tui and add snmp:udp

 

now in Xenserver 7 it is not available anymore so i edited the file iptables directy to add :

 

-A RH-Firewall-1-INPUT -m conntrack --ctstate NEW -m udp -p udp --dport 161 -j ACCEPT

 

is it hard to make it start as delayed service ? i don't find the proper setting with chkconfig or systemctl.

 

i think it might be because it's trying to start before the network service starts ?

 

if it would be firewall problem even when i restart apcupsd service it wouldn't work.

Link to comment
  • 0

In my iptables file I have:

 

-A RH-Firewall-1-INPUT -s W.X.Y.Z -p udp -m udp --dport 161 -j ACCEPT

 

where W.X.Y.Z is th eIP address of my SNMP server, and it's just before the last line

-A RH-Firewall-1-INPUT -j REJECT --reject-with icmp-host-prohibited

 

You will I believe need to restart the iptables service to put changes into effect that you edit in manually:

 

service iptables restart

 

or

 

systemctl restart iptables

 

-=Tobias

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...