Jump to content
Welcome to our new Citrix community!

Remove Xenapp 7.13 from programs (storefront component)


Recommended Posts

Hello,

I have a pair of storefront servers, both running server 2016 & Storefront 7.15 CU4.

Both of these servers are in a server group (with the sites installed to c:\inetpub)

The servers were initially installed using the Xenapp install of 7.13. This let me install Storefront components to the D:\citrix folder.

I have since updated the servers to 7.15 LTSR CU4 (back in June).

I am fine with this, but the server keeps showing in a report of out of support software, that Xenapp 7.13 is intalled. I need to get this removed from add remove programs.

 

This upgraded fine on both servers.

The problem I have is that I am still showing Citrix XenApp 7.13 in 'programs and Features'. So I remove one of the servers from the server group. Uninstall Xenapp 7.13 from the server that I have removed out of the group. Obviously this removes both versions of Storefront.

I install storefront again, using the standalone component, rather than the complete installer. As such this installs the application to c:\program files\citrix.

When adding to the group it fails the replication of the components. I am guessing becasue the installdir on each server is different.

I believe I have 2 options, backup the storefront configuration & uninstall the software on both servers. reinstall the software & restore to 1 server & use that as a base of a new group (if the restore succeeds).

remove the software & re-install using the full xenapp iso. hopefully this will let me install to the d:\citrix folder. I should then be able to add to the group.

 

Is this possible / the best approach.

 

Thanks
Matt

 

Link to comment
Share on other sites

On 8/5/2019 at 5:42 PM, Matthew Riddler1709154367 said:

Hello,

I have a pair of storefront servers, both running server 2016 & Storefront 7.15 CU4.

Both of these servers are in a server group (with the sites installed to c:\inetpub)

The servers were initially installed using the Xenapp install of 7.13. This let me install Storefront components to the D:\citrix folder.

I have since updated the servers to 7.15 LTSR CU4 (back in June).

I am fine with this, but the server keeps showing in a report of out of support software, that Xenapp 7.13 is intalled. I need to get this removed from add remove programs.

 

This upgraded fine on both servers.

The problem I have is that I am still showing Citrix XenApp 7.13 in 'programs and Features'. So I remove one of the servers from the server group. Uninstall Xenapp 7.13 from the server that I have removed out of the group. Obviously this removes both versions of Storefront.

I install storefront again, using the standalone component, rather than the complete installer. As such this installs the application to c:\program files\citrix.

When adding to the group it fails the replication of the components. I am guessing becasue the installdir on each server is different.

I believe I have 2 options, backup the storefront configuration & uninstall the software on both servers. reinstall the software & restore to 1 server & use that as a base of a new group (if the restore succeeds).

remove the software & re-install using the full xenapp iso. hopefully this will let me install to the d:\citrix folder. I should then be able to add to the group.

 

Is this possible / the best approach.

 

Thanks
Matt

 

 

Hi Matt,

 

As you suggest I will export configuration and reimport after fresh install on C:\ drive,

By the way did you follow this article https://support.citrix.com/article/CTX217480?

 

Thanks

Arnaud

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...