Jump to content
Welcome to our new Citrix community!

Keyboard cursor jumps when connected to VDA through Netscaler HTML5 client


Recommended Posts

Hello,

 

Catched strange behavior when connectiong to VDA (Remote Desktop Server - session-based) through Netscaler using HTML5 client.

 

In some fields when typing text coursor jumps to beginning of string and replaces 1st letter, this issue only appers with some letters, I found 'a', 'r', 'k'

Also I have 2 keyboard layouts at server US and RU.

When cursor is in "bad" field - I can't change language, even when change to RU manually in language bar it remains English.

 

For example I start "mstsc" application

- I can enter server name without any issues

- then credentials promtp for user/password - I cannot enter username correctly (described issue)

I tried to connect from 3 different PCs (Win10) - same behavior.

 

When connecting directly to Storefront with HTML5 client or using Citrix Workspace - no any issues, I facing it only when connecting through Netscaler HTML5 client (X1 theme).

 

I tried to add IgnoreRemoteKeyboardLayout option. but without success:

"reg add “HKLM\SYSTEM\CurrentControlSet\Control\Keyboard Layout” /v IgnoreRemoteKeyboardLayout /t REG_DWORD /d 0x00000001 /f"

 

My Config:

Netscaler (ICA Proxy)(13.0.37.27)  ---  XenDesktop (Controller + Storefront)(7_1906)  ---  VDA (App Publishing) (Windows Server 2016)

 

 

Is anyone have idea how han I fix this?

 

UPDATE:

Same behavior if I leave only EN layout. Affected only Credentials prompt window, cannot reproduce it in any other windows.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...