Jump to content
Welcome to our new Citrix community!
  • 0

Xen Hypervisor 8.0 installation on HP ProLiant 320e Gen8 (B120i RAID controller issue)


Borisa Bjelica

Question

Hi all, 

 

I need help installing Xen Hypervisor on Logical volume (RAID1 made of 2 disks using B120i RAID controller). 

When I come to destination disk selection, both physical disks and one logical drive are selectable (which is strange, should be normally only logical drive, right?). 

 

After I select only logical drive for both Xen installation and VM storage following error occurs at 45% (please find the picture attached).

 

After digging around I found that CentOS is not support by this hardware, but RedHat is, and we can find redhat RPM..that of course works fine with CentOS. 

 

Here is how people solve this problem with CentOS 7 installation http://josafatisai.blogspot.com/2016/01/installing-centos-7-on-hp-proliant.html

 

Is there a way to send similar parameters to Xen Hypervisor to ask for hpvsa driver during boot? Tried to boot: menu.c32, then tab to get to kernel parameters..passed the ones that work with CentOS but no luck. Boot continues as normal.

 

Can this driver be installed on Xen like this, or to create Supplemental Pack and try that way. But also saw that RPM for CentOS 7.5 can't be installed on Xen Hypervisor 8.0 (missing multiple kernel dependencies).

 

Thanks in advance

 

 

 

 

B120i error.jpg

Link to comment

14 answers to this question

Recommended Posts

  • 0

We tried to install XCP-ng on top of B120i RAID controller and no luck. Installation went fine, but on boot we hit kernel panic (picture attached). 

 

After that we disabled B120i and used Software RAID XCP-ng feature. Installation went fine. 

 

Big like to XCP-ng and thank you all guys for help. 

kernel panic.jpg

  • Like 1
Link to comment
  • 0
2 hours ago, Alan Lantz said:

I would look at the drives too, are they 4k ? Those aren't supported yet.

 

--Alan--

 

Hi Alan, 

 

HDD details:
 

/dev/sda:

 

ATA device, with non-removable media

Model Number:       MB1000GCEEK                             

Serial Number:      WCAW35HE6RPS        

Firmware Revision:  HPG1    

Transport:          Serial, ATA8-AST, SATA 1.0a, SATA II Extensions, SATA Rev 2.5, SATA Rev 2.6, SATA Rev 3.0

Standards:

Used: unknown (minor revision code 0x0028) 

Supported: 8 7 6 5 

Likely used: 8

Configuration:

Logical max current

cylinders 16383 16383

heads 16 16

sectors/track 63 63

--

CHS current addressable sectors:   16514064

LBA    user addressable sectors:  268435455

LBA48  user addressable sectors: 1953525168

Logical  Sector size:                   512 bytes

Physical Sector size:                   512 bytes

device size with M = 1024*1024:      953869 MBytes

device size with M = 1000*1000:     1000204 MBytes (1000 GB)

cache/buffer size  = unknown

Form Factor: 3.5 inch

Nominal Media Rotation Rate: 7200

Capabilities:

LBA, IORDY(can be disabled)

Queue depth: 32

Standby timer values: spec'd by Standard, with device specific minimum

R/W multiple sector transfer: Max = 16 Current = 8

Advanced power management level: disabled

DMA: mdma0 mdma1 mdma2 udma0 udma1 udma2 udma3 udma4 udma5 *udma6 

    Cycle time: min=120ns recommended=120ns

PIO: pio0 pio1 pio2 pio3 pio4 

    Cycle time: no flow control=120ns  IORDY flow control=120ns

Commands/features:

Enabled Supported:

  * SMART feature set

  * Power Management feature set

    Write cache

  * Look-ahead

  * WRITE_BUFFER command

  * READ_BUFFER command

  * NOP cmd

  * DOWNLOAD_MICROCODE

    Advanced Power Management feature set

    Power-Up In Standby feature set

  * SET_FEATURES required to spinup after power up

  * 48-bit Address feature set

  * Mandatory FLUSH_CACHE

  * FLUSH_CACHE_EXT

  * SMART error logging

  * SMART self-test

  * General Purpose Logging feature set

  * WRITE_{DMA|MULTIPLE}_FUA_EXT

  * 64-bit World wide name

  * IDLE_IMMEDIATE with UNLOAD

  * WRITE_UNCORRECTABLE_EXT command

  * {READ,WRITE}_DMA_EXT_GPL commands

  * Segmented DOWNLOAD_MICROCODE

  * unknown 119[7]

  * Gen1 signaling speed (1.5Gb/s)

  * Gen2 signaling speed (3.0Gb/s)

  * Gen3 signaling speed (6.0Gb/s)

  * Native Command Queueing (NCQ)

  * Phy event counters

  * NCQ priority information

    DMA Setup Auto-Activate optimization

  * Software settings preservation

  * SMART Command Transport (SCT) feature set

  * SCT LBA Segment Access (AC2)

  * SCT Error Recovery Control (AC3)

  * SCT Features Control (AC4)

  * SCT Data Tables (AC5)

    unknown 206[12] (vendor specific)

    unknown 206[13] (vendor specific)

Logical Unit WWN Device Identifier: 50014ee2614b92d4

NAA : 5

IEEE OUI : 0014ee

Unique ID : 2614b92d4

Checksum: correct

Link to comment
  • 0
2 hours ago, Tobias Kreidl said:

Also, are you using software RAID by any chance, which is also not supported?

 

-=Tobias

Tobias,

 

We are using HP Dynamic Smart Array B120i RAID controller, and according to HP website that is software RAID (no luck for me I guess). 

 

"Enabling both an HP Dynamic Smart Array (software RAID) and an HP Smart Array (hardware RAID) Controller may lead to unexpected results when installing Windows Server or Linux via HP Intelligent Provisioning."
 

Link to comment
  • 0
14 minutes ago, Tobias Kreidl said:

Ouch, that may be the issue right there: software RAID is not supported under any Citrix XS/Hypervisor releases.

 

-=Tobias

Yes. We installed XS 6.5 back then, but only on one of the disks. Logical drive wasn't even visible in destination disk selection. 

With XenServer 7.0 and newer, we can select logical drive but couldn't finish the installation. 

 

Looks like we'll have to replace those servers. 

 

Thank you very much for your support. 

Link to comment
  • 0
3 hours ago, Jose Pablo Benavides said:

This server is not on the compatibility list, even though you get to install it somehow, you might have other issues later and it will not be supported.

 

If it will be for production use, i dont recommend you go this way.

 

http://hcl.xenserver.org/servers/

 

Yes, saw that but I thought I could make it install somehow, because I saw success stories with CentOS.

 

Thanks

Link to comment
  • 0

XCP-ng finished installation on Logical Drive successfully, but didn't boot (kernel panic picture attached). 

 

After that we used Software RAID XCP-ng feature, installed and all works perfectly. 

 

We tested Linux software RAID by unplugging one of the disks, and all was OK.

 

Big like for XCP-ng, and thank you all guys for help. 

kernel panic.jpg

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...