Jump to content
Welcome to our new Citrix community!
  • 0

Impossible to install/update workspace app earlier than versions 1903


Andy Zanny

Question

Hello to all

I'm using Workspace app to work, the last working version installed is the 1903, all the next releases don't update the current one.

If I uninstall completely the 1903 version, run its cleanup utility, run CCleaner, run Wise Registry cleaner, reboot and try to install the version 1905 or the latest 1907, I got always an error message that stops the installation (see the file loaded)

If I install the 1903 again it works perfectly

 

This problem happen with my laptop with windows 10 Pro x64 v. 1903 AND with my desktop computer with the same Windows version, both fully updated, no third parties Antivirus installed anywhere

 

Any ideas?

TrolleyExpress-20190717-140119.log

Link to comment

6 answers to this question

Recommended Posts

  • 0

Good morning,

 

After reviewing the attached log file, the following stands out to me:

 

Quote

14:01:34: Information - CApp::IsRequireToInstallVCRedist(2413) - Checking for isntalled VC Redist 2017
14:01:34: Information - CApp::IsRequireToInstallVCRedist(2418) - Found the installed VC Redist version details as ,  14.11.25325.00
14:01:34: Information - CApp::IsRequireToInstallVCRedist(2422) - Need to trigger installation for 32 bit VC Redist
14:01:34: Information - CInstallationManager::InstallComponents(1828) - Proceeding with Packages installation

14:01:34: Information - CInstallationManager::InstallPackage(3564) - Extracted Location found: C:\Users\Little Andy\AppData\Local\Temp\Ctx-079B3F5D-AA49-4D01-945C-97C49D97E439\Extract\\PackageInstaller.exe /silent /norestart
14:01:34: Information - CInstallationManager::InstallPackage(3590) - Failed at creating process to install PackageInstaller PackageInstaller.exe, With Error Code : 193
14:01:34: Information - CInstallationManager::InstallPreRequisitePackage(3640) - Return value of InstallPackage is 193
14:01:34: Error - CInstallationManager::InstallPreRequisitePackage(3665) - Installation has failed, hence aborting the installation of Citrix Workspace : 193
14:01:34: Information - CApp::SetExitCode(144) - Exit code is 20193 (called with 20193)
14:01:34: Information - CInstallationManager::InstallPreRequisitePackage(3671) - Uninstalling the Package Installer
14:01:34: Information - CInstallationManager::InstallPackage(3564) - Extracted Location found: C:\Users\Little Andy\AppData\Local\Temp\Ctx-079B3F5D-AA49-4D01-945C-97C49D97E439\Extract\\PackageInstaller.exe /silent /uninstall /norestart
14:01:34: Information - CInstallationManager::InstallPackage(3590) - Failed at creating process to install PackageInstaller PackageInstaller.exe, With Error Code : 193
14:01:34: Information - CInstallationManager::InstallPreRequisitePackage(3673) - Return value of InstallPackage after uninstall is 193
14:01:34: Error - CInstallationManager::InstallComponents(1832) - PreRequisite Packages Installation Failed

 

Can you try uninstalling the VC++ Redistributable 2017 and try again?  If nothing else, this will at least eliminate that prerequisite as being the issue.

Link to comment
  • 0

Hello, thanks for your feedback

I'm downloaded the last Visual C++ 2017 libraries (15.9) and installed both versions (x86 and x64)

Installed the last Workspace app (19.7) and it complete succesful, unfortunately as soon as I lunch Firefox (68.0 x64), click on the link I have to connect and work, Workspace give me the error loaded

I run Citrix diagnose utility and here you can find the loaded report

I got the same problem when I tryed with the version 1905, this is another reason why I must keep the 1903 one

 

Thanks in advance

ctrx_error.jpg

ReceiverDiag_20190717_162126644.zip

Link to comment
  • 0

Uhmmmm....

seems that my customer have to update something

Is it possible that where I have to connect is not fully updated and it is not supporting earlier versions than 1903?

In that case I can't do anything, it's not my fault (or my computer)

 

Thanks in advance

Link to comment
  • 0

So you are the end-user in this instance and the customer owns the Citrix infrastructure you are connecting to?

 

It sounds like you are correct in your line of thinking that you cannot do anything (except stay at version 1903) on your end to address the issue.

 

The customer would have to review the Citrix Support article I posted above and take the appropriate action.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...