Jump to content
Welcome to our new Citrix community!
  • 0

Windows guest VM sometimes loses network connection


Vasiliy Osipchuk

Question

Hi all.

I have: 

Xenserver XS76 with updates XS76E00-3

CPU E5-2630 v4 @ 2.20GHz

6 SATA hdd raid 10

2 SATA SSD raid 1

Sorry for my English

Several virtual machines with Windows server.
Sometimes the ping to the terminal server increases to 2-3 seconds or disappears, after 3-8 seconds everything works as expected, the remaining VMs are working well at that time.
I run ping from the XS host console.
Experimentally found that the loss of communication associated with the work of users in Google Chrome.
It is enough for me to open 5-7 tabs on YouTube and this already affects the connection for a few seconds.
If I run taskkill chrome.exe, the connection is normalized.
Improving the situation, I achieved a binding pcpu and vcpu. The frequency of breaks decreased from every 3-5 minutes to 1 time in 10-30 minutes.
During the breaks, I do not see a high load on the Dom0 cpu and VM cpu in the xencenter performance tab, but the system monitor of Windows shows high values of the ipv4 datagrams counter.
Terminal VM is stored on SSD.
I will be glad to any advice.

 

Link to comment

18 answers to this question

Recommended Posts

  • 0
51 minutes ago, Tobias Kreidl said:

Hmm. No network or server CPU/memory limitations as far as you can tell?

 

-=Tobias

No, this is a fresh installation of the XenServer and the Windows VM. I did not make any conscious restrictions. The only restriction is the number of the vcpu in the VM properties - 8pcs and all of them are pinned exclusively for 8 pcu.

Link to comment
  • 0
11 hours ago, Alan Lantz said:

Earlier versions of XenTools had issues with load, what version of XenTools do you have on the VM ? 

The latest is 7.1.0.1396.

 

--Alan--

 

I do not understand where to look at the version of Xentools in the Windows system.
In the properties of the xenlegacy file of the XenServer tools iso image is version 7.0.1.61916.

Link to comment
  • 0
6 minutes ago, Alan Lantz said:

You can find the version in your list of installed applications.

 

--Alan--

 

in my list of installed applications  i see from publisher Citrix only "Citrix XenServer Windows Management Agent" and he has version 7.1.1270, which is significantly different from the version that you wrote

Link to comment
  • 0
10 hours ago, Alan Lantz said:

1229/1270 was about the time they fixed that issue with load, so you're probably good on the agent. 

If you want the latest you can always go to:

 

https://support.citrix.com/article/CTX235403

 

--Alan--

 

 

Thank you for the link. I searched for it for a long time while I tried to solve the problem on my own. I will try to update XenTools in the evening.

Link to comment
  • 0
8 hours ago, Tobias Kreidl said:

The other question is whether you are having a true network issue (bad connection or errors on the Ethernet port, cable, I/O timeout etc.). Have you looked in various logs for additional clues?

 

-Tobias

Nothing that would indicate something like that - the connection to the rest of the VM and with the host itself is stable. I looked at all the logs in /var/log/ on XS host but did not find any errors there.

The problem arises itself, as far as I can tell, only with a VM in which the network load and/or other load increases.
Today I discovered a new aspect of the problem. During the failure of communication with the VM, not only the datagram TCP counter increases, but also the average disk queue counter increases. Sometimes they grow together, sometimes each separately. Both counters I look inside of Windows VM.

It seems to me that this is important.

 

Link to comment
  • 0
32 minutes ago, Tobias Kreidl said:

SATA-based RAID with relatively few spindles - if that's where you VM is stored - might be a bottleneck. Run "iostat -x 10" which will show you the I/O stats and queue statistics every 10 seconds for all your storage devices. See if any of the values are resource-limited.

 

-=Tobias

No, Terminal VM is stored on SSD.

Link to comment
  • 0

Thanks for the help guys.
Since for several days already the connection with the VM has been working well, I believe that I solved the problem.
As it turned out, the connection breaks also coincided with a surge in load on the CPU from the side of system interrupts. I found out that the xenvif driver takes the most CPU time. The next thing I did was to add second Intel xeon CPU to the server and increased the number of vCPU in the problem VM. And on the same day I updated the Management Agent by link Alan Lantz. The previous xenvif driver has minor version 170. I am almost sure that the solution to the problem was to update the drivers and the increase in computing resources played no significant role.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...