Jump to content
Welcome to our new Citrix community!
  • 0

Running Citrix Workspace on Fedora 30


Tomas Hulla

Question

Hello,

 

I have downloaded rpm from citrix website. I have Fedora 30.

 

Running $ /opt/Citrix/ICAClient/util/ctxwebhelper caused to miss libcrypto.so.1.0.0 and libssl.so.1.0.0

 

so I did

# ln -s /usr/lib64/libcrypto.so.1.0.2o /usr/lib64/libcrypto.so.1.0.0

#ln -s /usr/lib64/libssl.so.10 /usr/lib64/libssl.so.1.0.0

 

After running $ /opt/Citrix/ICAClient/util/ctxwebhelper again, I get:

 

/opt/Citrix/ICAClient/util/ctxwebhelper: /lib64/libcrypto.so.1.0.0: version `OPENSSL_1.0.1d' not found (required by /opt/Citrix/ICAClient/util/ctxwebhelper)
/opt/Citrix/ICAClient/util/ctxwebhelper: /lib64/libcrypto.so.1.0.0: version `OPENSSL_1.0.0' not found (required by /opt/Citrix/ICAClient/util/ctxwebhelper)

 

Is there any suggested way what to do about this?

 

Thank you,

 

Thomas

Link to comment

3 answers to this question

Recommended Posts

  • 0

Hi, I'm not running fedora.

 

But maybe it's a known issue:

https://docs.citrix.com/en-us/citrix-workspace-app-for-linux/whats-new.html

 

Quote

ICA launch might fail on Fedora 29/30. As a workaround, follow the steps:

Install openssl10 by using the command sudo yum install compat-openssl10.x86_64

Set the environment variable in ~/.bashrc to load for every session. This action points to the older libcrypto library. export LD_PRELOAD=/lib64/libcrypto.so.1.0.2o

 

Link to comment
  • 0

Hello, thanks for your answer. Unfortunately that does not work. 

 

$ sudo dnf install compat-openssl10.x86_64
Last metadata expiration check: 0:24:03 ago on Thu 29 Aug 2019 04:11:54 PM CEST.
Package compat-openssl10-1:1.0.2o-5.fc30.x86_64 is already installed.
Dependencies resolved.
Nothing to do.
Complete!
$  /opt/Citrix/ICAClient/util/ctxwebhelper
/opt/Citrix/ICAClient/util/ctxwebhelper: /lib64/libcrypto.so.1.0.0: version `OPENSSL_1.0.1d' not found (required by /opt/Citrix/ICAClient/util/ctxwebhelper)
/opt/Citrix/ICAClient/util/ctxwebhelper: /lib64/libcrypto.so.1.0.0: version `OPENSSL_1.0.0' not found (required by /opt/Citrix/ICAClient/util/ctxwebhelper)
$ export LD_PRELOAD=/lib64/libcrypto.so.1.0.2o
$  /opt/Citrix/ICAClient/util/ctxwebhelper
/opt/Citrix/ICAClient/util/ctxwebhelper: /lib64/libcrypto.so.1.0.2o: version `OPENSSL_1.0.1d' not found (required by /opt/Citrix/ICAClient/util/ctxwebhelper)
/opt/Citrix/ICAClient/util/ctxwebhelper: /lib64/libcrypto.so.1.0.2o: version `OPENSSL_1.0.0' not found (required by /opt/Citrix/ICAClient/util/ctxwebhelper)

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...