Jump to content
Welcome to our new Citrix community!
  • 0

.ICA not opening


Jinky Sagun

Question

I have logged in to my Citrix account. It shows the apps available to me to open. When I click on any of them, it prompts to Open or Save the .ica file. When I hit either Open or Save, nothing happens. Cursor shows as loading (spinning) for a few seconds then back to the normal arrow cursor. I have already checked - the default program for .ica is Citrix Receiver. I have a Windows 10 machine. I used my work machine (Windows 7) and it did work there. I have tried IE and Chrome - nothing works. Help!

Link to comment

3 answers to this question

Recommended Posts

  • 0

Have you gone through this article?  

 

https://support.citrix.com/article/CTX804493 - Users Prompted to Download, Run, Open Launch.ica File, Instead of Launching Connection

 

Lots of good information in there from a troubleshooting perspective.

 

Additionally, test using Citrix Quick Launch (https://support.citrix.com/article/CTX219718) to make sure you are seeing the expected behavior without using a browser.

 

There is also a Chrome specific article, although I realize you are seeing this issue regardless of browser.

 

https://support.citrix.com/article/CTX136578 - Google Chrome not Opening Launch.ica Files

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...