Jump to content
Welcome to our new Citrix community!
  • 0

grey screen appears and disappears..tried all workarounds


Question

I am using version LinuxVDA-1903.ubuntu16.04

Fresh ubuntu 16.04 install.
No issues registering with the controller.
Installed Xorg etc
VDA.log shows

The Citrix Desktop Service detected that a user session has ended. Session 'xxxx' for user 'username' has ended; reason code 'Logoff'.

 

This has been driving me crazy for the past 3 days. Tried all workarounds..Help needed

 

Link to comment

4 answers to this question

Recommended Posts

  • 0

My my experience, most of these types of desktop disappearing issues can be contributed to the users .cshrc or .bashrc other .dot files having something incorrectly set. Moving them temporarily to a backup folder to try to get a successfully VDI desktop, then copy them back one by one is a good way to debug.

Typical culprits of VDI not being able to get a session that i have seen are:

 

.cshrc

.bashrc

.bash_profile

.bash_login

.profile

.login
 

I've seen this in some users home directory in the .bashrc or .cshrc . Commenting out these two lines seemed to work for them.

 

.bashrc

# No autologout

#set autologout=0

 

# Autocomplete

#set autolist

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...