Jump to content
Welcome to our new Citrix community!
  • 0

Unable to add/update a machine to an existing catalog


Gregory Moore

Question

Good day everyone. 

 

i know we've seen this question before but I hae an issue where I cannot add/update a machine catalog.

 

Below is the error message that I get via MCS....

 

Task Information:

Start Date: Tuesday, July 2, 2019

Start Time: 3:25 PM

Finish Date: Tuesday, July 2, 2019

Finish Time: 3:25 PM

State: Failed

Requested machine count: 1

AD account action: Create accounts

Successful accounts: 1

Successful machines: 0

 

Machine Failures: DOMAIN\COMPUTERNAME$: Failed to create the virtual machine; DOMAIN\COMPUTERNAME$. Inner Error: The object 'vim.Folder:group-v2500' has already been deleted or has not been completely created

 

ErrorID : PluginUtilities.Exceptions.ManagedMachineGeneralException

 

TaskErrorInformation : PluginUtilities.Exceptions.ManagedMachineGeneralException: The object 'vim.Folder:group-v2500' has already been deleted or has not been completely created ---> PluginUtilities.Exceptions.ManagedMachineGeneralException: The object 'vim.Folder:group-v2500' has already been deleted or has not been completely created ---> PluginUtilities.Exceptions.WrappedPluginException: The object 'vim.Folder:group-v2500' has already been deleted or has not been completely created

 

--- End of inner exception stack trace ---

at Citrix.PoolManagement.VMManager.VmmImplementation.Vmware.VmwareVmManager.Intercept(Exception e)

at Citrix.PoolManagement.VMManager.VmmImplementation.Vmware.VmwareVmManager.CreateCompleteVM(String name, IVMMetadata metadata, Int32 cpuCount, Int32 memory, String storageId, String dataCenterPath, ManagedObjectReference resourcePool, INetworkInterfaceDetails nics, Boolean enableNetwork, Boolean tagVms, IList`1 disks)

at Citrix.PoolManagement.VMManager.VmmImplementation.Vmware.VMwareHypervisor.<>c__DisplayClass16.<BeginCreateCompleteVM>b__13(VmwareVmManager manager)

at Citrix.HypervisorCommunicationsLibrary.TaskRunItem`2.Run(T manager)

at HypervisorsCommon.HCL.TaskRunner`1.Run()

--- End of inner exception stack trace ---

 

Server stack trace:

at HypervisorsCommon.HCL.TaskScheduler`1.CompleteTask(IAsyncResult result)at Citrix.PoolManagement.VMManager.VmmImplementation.Vmware.VMwareHypervisor.EndCreateCompleteVM(IHostingUnitDetails hostingUnit, IAsyncResult result)

at Citrix.HypervisorCommunicationsLibrary.AddInSideAdapter.IHypervisor_AddInViewToContractAdapter.EndCreateCompleteVM(IHostingUnitDetailsContract hostingUnit, IAsyncResult result)

at System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateProcessMessage(IntPtr md, Object[] args, Object server, Object[]& outArgs)

at System.Runtime.Remoting.Messaging.StackBuilderSink.SyncProcessMessage(IMessage msg)

 

Exception rethrown at [0]:

at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)

at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)

at Citrix.HypervisorCommunicationsLibrary.Contracts.IHypervisorContract.EndCreateCompleteVM(IHostingUnitDetailsContract hostingUnit, IAsyncResult result)

at Citrix.HypervisorCommunicationsLibrary.HostSideAdapter.IHypervisor_ContractToHostViewAdapter.EndCreateCompleteVM(IHostingUnitDetails hostingUnit, IAsyncResult result)

at Citrix.MachineCreation.NewProvVMSupport.NewProvVMLogic.CreateVmCallback(IAsyncResult result)

 

Here's how the environment is set up:

* XD environment is a mixture of persistent and non-persistent machine catalogs

* On vSphere hypervisor, ALL golden images are created under a folder for each machine catalog; snapshots are removed after creation of VMs in Studio but the golden image remains with the created vms

* Hypervisor version is 6.54

* XD is 7.15 CU3

 

I can create a new catalog and machines without issue and once those catalogs are created, updating them are not a problem. The issue is with an EXISTING machine catalog; no matter what kind of vm is created.

 

Has anyone fixed this issue yet for THIS particular problem?

 

Link to comment

5 answers to this question

Recommended Posts

  • 0

Hi Gregory,

 

Did this issue start after upgrading VMware? Since you aren't facing any issues with creating and updating new machine catalogs, I am suspecting that there was a VMware upgrade due to which you cannot update the old machine catalog that were created while on the older version of VMware.

Link to comment
  • 0

You can give it a try. Creating a new resource might or might not solve the issue. 

But, if you want to know the root cause for this issue, I guess you will have to discuss with your VMware team. Because, it looks like, the Delivery Controller is giving the commands successfully to the hypervisor, but the hypervisor throws this errors: " Failed to create the virtual machine", "The object 'vim.Folder:group-v2500' has already been deleted or has not been completely created". So, you will have to get that checked as to why VMware is unable to create the machine account.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...