Jump to content
Welcome to our new Citrix community!
  • 0

Grey border + stuck extra mouse cursor on Windows server 2016 XenDesktop


Wouter Van Casteren

Question

I'm building an image for Windows Server 2016 Professional (version 1607). The problem is that when the desktop opens there is a mouse cursor stuck on the desktop , usually in the middle of the screen, I still can move around my mouse cursor and click. Another problem is that the desktop doesn't resize, when I maximize the screen the size of the desktop stays the same and the rest of the screen is filled up with grey borders.

According to what I've read this could be caused by HDX3D Pro but if I'm not mistaken this can be only be installed on a Windows 7/Windows 10 desktop VM.

This topic (https://discussions.citrix.com/topic/390221-grey-border-around-ica-session-desktops/) has the same problem but we don't use the NVidia grid card unless I've accidentally enabled it somewhere.

In this topic I found the same problem with the mouse cursor (https://discussions.citrix.com/topic/385363-second-mouse-pointer-in-the-middle-of-the-screen/) and legacy graphics are indeed enabled. I used the command wmic /namespace:\\root\citrix\hdx path citrix_virtualchannel_graphics get /value and the Citrix HDX monitor to check this. I wanted to try and force a different graphics mode by disabling legacy graphics in the Citrix policies but legacy mode stays active. Can I change this in the registry maybe?

 

We are using 7.15 CU 3 and the VM's are hosted on VMWare ESXi 5.5.

 

Thanks in advance and kind regards,

Wouter

 

Link to comment

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...