Jump to content
Welcome to our new Citrix community!
  • 0

Can't connect to external website using SSL without resetting Internet Explorer 11


Matthew Anstis

Question

Hi All 
Windows 10 , Internet Explorer 11. Staff connect to an external website requiring Citrix Receiver. There is also an SSL certificate securing the external website.  A small percentage of staff have regular issues with connecting to the website and I believe it is a Citrix ICA Client Active X control issue. 
  
The issue is: When connecting to the particular website, a windows security box appears asking to  "confirm certificate". After that IE 11 freezes  and only an IE reset  and reboot seem to fix the issue for a few days to a week, then it comes back. The next pop up should have been "Windows Security Credential Required - Do you want the App to access your private key?"  
  
I understand I can implement logging on Citix receiver - would this be a good way to troubleshoot the issue and if so how would I implement please?? 
  
Compatibility mode, allowing pop ups have been tried. I have deleted the SSL state. Active X filtering is off. Smart screen is off.  
This may have worked but yet to confirm :  Renaming:  HKey Classes Root\protocols\Filter\application/x-ica 
I don't have a copy of task manager but the netlogon service(s) consumed about 50% of CPU. 
Can anyone help please? 
Kind regards 
Matt 

Link to comment

1 answer to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...