Jump to content
Welcome to our new Citrix community!
  • 0

XenServer 7.1 CU2 Problem at Pool Join - Update Different


Peter Keller

Question

Hello everyone,

 

I have reinstalled a host and also applied all updates the master is using. But I can't join the pool it says "The hosts in this pool are not homogeneous.
reason: Updates on local host wvmxen10 and pool host wvmxen12 differ" But as far as I see they don't. I have already changed the pool-master to another using the same updates and also re-installed the host again and it still doesn't work.

I even compared xe-update-list and seems same. Re-Installing xen 11, 12 and 13 worked well.

 

Thank you.

 

Regards

Peter

 


 

2019-06-24 16_30_16-Dokument2  -  Kompatibilitätsmodus - Word.jpg

Link to comment

13 answers to this question

Recommended Posts

  • 1

Solved it!

 

After I have updated any host of the pool to a fully applied patch-level was able to join. 

As I started we had a heterogen pool with different CPUs and while I re-installed the host I also made a pool split to get same CPUs in one pool. (So we have receive a homogen pool)

So I learned with the homogen pool the update-level have to be fully applied to join a new host.

 

 

Thanks you for you help.

 

Greetings

Peter

  • Like 2
Link to comment
  • 0

Are they the identical server hardware and have the identical BIOS/firmware updates?

Run "xe host-cpu-info" and compare thge features setting on each to see how similar or not they are.

Worst case, you might risk using the CLI and forcing the host to joint the pool:

 

# xe help pool-join
command name            : pool-join
        reqd params     : master-address, master-username, master-password
        optional params : force
        description     : Instruct host to join an existing pool.

 

-=Tobias

Link to comment
  • 0

Hi Tobias, thanks for answering.

 

Yes they are all Cisco UCS B200 M4 and coming with the same prerequisites.

"xe host-cpu-info" has differences  in features, flags and speed. (look attached files)

 

 

I've already tried this force:

#  xe pool-join force=true master-address=10.1.5.91 master-username=root master-password='xxxxxxxx'
The hosts in this pool are not homogeneous.
reason: Updates on local host wvmxen10 and pool host wvmxen12 differ

 

Thanks a lot.

 

Greetings

Peter
 

 

2019-06-25 07_50_54-_new 1 - Notepad++.jpg

Link to comment
  • 0

Aha, in spite of what your XenCenter reprots, apparently there is a discrepancy in the updates. Have both been rebooted since being updated?

 

Try running "xe patch-list params=all" on both hosts and compare the outputs, as there must be some reason they are different since that's what the pool join command is complaining about!

 

-=Tobias

Link to comment
  • 0

I compared patch-list and they are exactly same patch level.

 

As far as I see in comparing the UCS Servers in BIOS and Firmware they are similar.

 

The CPU features of the xen10 has been increased yesterday after retrying to join the pool and are now the same as in the pool (xen12) but I am still not able to join.

 

Some further information, we had two older xen servers I have splitted them up in another cluster and I am not sure if there could be any leftovers like updates they had applied. I thought this should be irrelevant after removing xen 1+2 out of the pool and designated a new pool master.

 

Thanks.

 

Peter

 

Link to comment
  • 0

You could always try to use the CLI command along with the --force" option.  Again, it would be good to know the exact error that comes from using the CLI command without forcing it.

 

Along the lines of confusion of the state of hotfixes and the master, maybe first try "xe pool-sync-database" to make sure all nodes are in sync.

 

-=Tobias

Link to comment
  • 0

I had already designated xen12 to master I now tried it again with xen11. Same result.
The other hosts in this pool (xen03-09) have not the same update-level.

PVS-Accelerator (version 0.1.0+2)
XS71ECU2 (version 1.0)
XS71ECU2001 (version 1.0)
XS71ECU2002 (version 1.0)
XS71ECU2003 (version 1.0)
XS71ECU2004 (version 1.0)

 

Screenshots attached to see what is the update-level from the host inside and outside the pool.

Also a screenshot from trying to join with cli.

 

I have sync the db, could this db be damaged because of the pool split or have leftovers?

 

Thanks for helping.

 

Peter

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...