Jump to content
Welcome to our new Citrix community!
  • 0

Hypervisor ISO Datastore is extremely slow


Matt Rose1709161062

Question

I've use XenServer off and on for many years so I am fairly familiar with how it works.  I have an existing Xen 7.0 system that has been up and running for years, no issue.  This week I stood up a new Citrix Hypervisor 8 system on a Cisco c220 m3.  It is a beefy system with 128 gb ram and 16 cores.

 

One of the first things I did was connect it to an existing NFS ISO datastore.  It was odd that the operation took ~30 seconds and the box eventually went away, and the datastore did appear but with no ISOs on it.  I had to manually perform a rescan to get my ISOs to show up.  This is the same datastore that my Xen7 system is attached to so I know there is not a problem with it.

 

When I tried to install an operating system from the datastore it is unacceptably slow i.e. I let it run over night and my Win 10 install status bar is at 40% done after about 10 hours.

 

My CH8 system only has a single nic attached so everything is running over a single connection.  I have tried connecting to my ISO datastore via nfs3, nfs4, and cifs and my results are the same each time -- too slow to use.

 

I did import an xva into the system and it booted in seconds so at this time I have no reason to believe there are any problems outside of ISOs.  Any thoughts guys?

Link to comment

9 answers to this question

Recommended Posts

  • 0

For memory I show Citrix Hypervisor at 3.0 GB and Control Domain at 7.4 GB.  My CPU graph is completely flat as is my network throughput.  The win10 install is now at 70%.  Im going to let it finish to see how performance is after the install is actually done.  It shows as unlicensed right now.  I have installed XS80E001.  I will probably connect a 2nd nic just for storage and try that.  Right now I am using local storage on my server but I plan on eventually hooking it up to NFS NAS - the same NAS where the ISO data store is.

 

Looking through alerts and events, I see nothing of interest.  Im at a loss -- seems a bit bizarre.

Link to comment
  • 0

Saturated - no.  But I do see cpu on domain0 fluctuating from 10 to 25.  And I've got 64 gb of ram assigned to a win 10 vm.  I'm attempting 5 OS installs simultaneously.  The only one that seems to be generating any load in xentop is the one installing from a usb drive physically attached to the server (ubuntu)...

 

xentop - 13:42:36   Xen 4.11.1-7.3
5 domains: 1 running, 1 blocked, 0 paused, 0 crashed, 0 dying, 0 shutdown
Mem: 134191912k total, 110060240k used, 24131672k free    CPUs: 32 @ 2400MHz
      NAME  STATE   CPU(sec) CPU(%)     MEM(k) MEM(%)  MAXMEM(k) MAXMEM(%) VCPUS NETS NETTX(k) NETRX(k) VBDS   VBD_OO   VBD_RD   VBD_WR  VBD_RSECT  VBD_WSECT SSID
  Domain-0 -----r       1759   12.4    7766016    5.8    7766016       5.8    16    0        0        0    0        0        0        0          0          0    0
Ubuntu Bio --b---        118    3.6   15073280   11.2   15074304      11.2     4    0        0        0    2        0    13316    55332     810306    4010064    0
Windows 10 ------         15    0.0    4194304    3.1    4236288       3.2     6    0        0        0    1        -        -        -          -          -    0
Windows 10 ------         11    0.0   67108864   50.0   67660800      50.4    24    0        0        0    1        -        -        -          -          -    0
Windows 7  ------          5    0.0   12582912    9.4   12692480       9.5     8    0        0        0    1        -        -        -          -          -    0

Link to comment
  • 0

Added a secondary ethernet and create a storage IP address, created a NFS datastore for VMs as well as deleted and recreated the NFS ISO datastore.  Nothing seemed to be helping.  Then I had a momentary power outage, cause of a storm, and none of this lab is on battery yet...  Anyway, the host and the switch went down and when they came back up it is working much better now.    OS installs from iso data store are taking just a few short minutes.  @Alan I suspect you were right.  Only thing I can figure is, there was something goofy on my switch and the unintended reboot ironed it out.  It is a low end and very old Netgear managed switch.

 

Thanks all for chiming in with good thoughts, but I'll close this one out to false alarm.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...