Jump to content
Welcome to our new Citrix community!

Rewrite policies don't work with any non-html files


Recommended Posts

I'm trying to modify (add some stuff) to the NS gateway login page. The modifications are going into the gateway_login_view.js file. They do work when I modify the file manually however, I'm trying to use the rewrite policy for that. This doesn't seem to work. Moreover, the rewrite policies don't work with anything other than html files. Below is the simplest example I could come up with - this adds "test" to the end of the file.

 

add rewrite action test_a replace "http.RES.BODY(120000)" "http.RES.BODY(120000)+\"test\""
add rewrite policy test_p "HTTP.REQ.URL.CONTAINS(\"gateway_login_view.js\")" test_a
bind vpn vserver vServerName -policy test_p -priority 100 -gotoPriorityExpression NEXT -type RESPONSE

 

The policy is getting hits and If I change it to "index.html" then everything works as expected - "test" appears at the very end of the file. I tried other js files and css etc with the same result - it just doesn't work. It's the VPX ver 12.0 build 61.8.

 

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...