Jump to content
Welcome to our new Citrix community!

XenApp 7.16 - StoreFront - Receiver for Web - 8 Hours Session Timeout


Frederik Klein

Recommended Posts

Hello,

i have quite odd Phenomenon with my Citrix Netscaler/ StoreFront installation and to be precisely with a log-off time out.

Due to requirements of our external employee we want to set the log-off timeout for our Receiver for Web up to 8 hours. But so far the Receiver for Web Site always disconnects after about 5 hours despite previously set higher timeout values.  After 5 hour the Web Session is still open, but as soon as i start an App, i get the Massage „Your Session is expired. Please Log-In“. After clicking on the log-in button i get back to the Website without a re- authentication via the Netscaler.

 For me, that's an indication that this is a timeout issue on StoreFront.

Those are the values i have adjusted so far to achieve a permanent 8 hours login in our Receiver for Web.

 

Adjust the Time-Out Value on our Netscaler VPX Seesion Profile to 8  hours

Netscaler>Sessions>Session Profile> Client Experience> Session Time-Out

Adjust the  sessionState timeout value in the Web.Config of the Receiver for Web Site.

On the Netscaler is no Load Balancer in use.

 

Is there a Value i missed that is importent to achive my goal?

 

Thx for your help.

 

Best reagards

Link to comment
Share on other sites

Hi,

 

If you increase the session timeout for the Citrix Receiver for Web to be more than one hour, you also have to increase the token maximum lifetime appropriately in the Authentication Service.

 

On StoreFront, navigate to c:\inetpub\wwwroot\Citrix\Authentication.
In the web.config file, locate the entry: <defaultLifetime="01:00:00" maxLifetime="01:00:00">
Change the maxLifetime to desired value.

 

If the desired timeout value is greater than eight hours, edit the web.config file under Citrix Receiver for Web to increase the Authentication token lifetime:

On StoreFront, navigate to c:\inetpub\wwwroot\Citrix<StoreWeb>.
Locate the entry: <authentication tokenLifeTime="08:00:00" method="Auto" />
Change the tokenLifeTime to a desired value.

 

Reset IIS and test.

 

Update if it helps. :) 
 

Cheers,

Aseem

  • Like 1
Link to comment
Share on other sites

Hi Aseem,


thx for your answer.

  

Unfortunately, setting the authentication tokenLifeTime to 8 hours did not solve the problem. The WebSession logs off after about 5 hours. It may be the AppPool Recycling TimeOut of the IIS, but so far I have not dared to set the AppPool to a certain time, as the website may be damaged.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...