Jump to content
Welcome to our new Citrix community!
  • 0

Application issue -SQL Developer- published app - profile related


Question

We are running 7.15 CU3 on Windows 2012 R2 . We have published SQL Developer 19.1 Windows 64-bit with JDK 8 included https://www.oracle.com/technetwork/developer-tools/sql-developer/downloads/index.html application. On 1st use, if the user does not have a UPM profile, the application launches and works correctly. After they logoff and launch the published application a 2nd time, the application opens normally, but certain functionality does not work, "new connection" window does not open.  Also reproduced the issue as a published RDP app using UPM. The same user can login to the server desktop and does not have any issues with the application. Deleting the profile, fixes the published app problem, but then it does not work on 2nd launch. If launching the application in debug mode, we see javavm errors when performing certain actions, these do errors do not occur on 1st use or desktop.

 

I disabled the UPM service, deleted profile and the published app works correctly.  I suspect UPM not syncing something. Appdata\Roaming\SQL Developer seems intact.  If i only delete this directory from the profile, I still have the issue, so it seems to be elsewhere.

 

Any suggestions on how to find the source of the issue ?

 

 

Link to comment

1 answer to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...