Jump to content
Welcome to our new Citrix community!
  • 1

SSL error on adding URL to Citrix Receiver


Iliya Iliev

Question

I am having an issue with importing the SSL certificate and adding my URL to Citrix Receiver on CentOS 7. 

 

The webstore works fine through the browser and I am able to add the URL in workspace app on Windows no problem but I can't get it to work on Linux. 

I have two servers. Serv1 running Studio, Delivery Controller and StoreFront and AD Certificate Services (issues the cert) Serv2 is a Worker VM that users initiate to. 

 

Th error I get is "an SSL Connection to the server couldn't be established because the server's certificate was not trusted". 

Ive tried to export the cert from Chrome and Firefox to /opt/Citrix/ICAClient/keystore/cacerts/ and run ./ctx_rehash with no luck. Also tried to convert it to .pem using openSSL. 

 

After i place the two certs into the /keystore/cacerts/ folder i get an different error  from the citrix receiver HTTP request failed. 

Does anyone have any ideas? Im stuck on this last step and its very frustrating. 

 

Thanks 

 

 

Link to comment

1 answer to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...