Jump to content
Welcome to our new Citrix community!
  • 0

XD & VDA 1903 - Graphic errors and overlays

Baumgartner AG


Hi Community


So we updated to 1903 last weekend. At the same time, we installed the new hardware, so its a bit difficult to determine where the problem is coming from.


We experience major graphic problems with our XenDesktop Sessions (see picture in attachement, left screen). Sporadically, graphic errors and overlays occur inside the session, especially when windows were moved around, enlarged or new programs are opened.




We didn’t experience those issues before in our test enviroment (HPE DL380 Gen10, NVIDIA Tesla P4).

Our Enviroment looks as folows:


Server:                                 HPE DL380 Gen10, 2x 3.20 GHz CPU, 2x NVIDIA Tesla T4


Hostdriver:                         418.66


Guest Driver:                     425.31


Hypervisor:                        Vmware ESXi 6.5 latest patch


Virtualization:                   Citrix XenDesktop and PVS 1903


VDA:                                     Windows 10 Enterprise 1803 with VDA 1903


Graphics Profile:              T4-2b, 12 VMs/Users working on this server


Client:                                  HP Z420 Workstation with Quadro K2000 and Citrix Workspace App 1902/1811


Citrix Policies:





Maybe someone was running into the same issue or can give some advice about what could probably cause the issue.


Thanks and regards, Cedy


Link to comment

16 answers to this question

Recommended Posts

  • 0
2 hours ago, James Kindon said:

I've had challenges with gpu and udp - things stabilised once EDT was disabled - not the exact same symptoms as yours but it's a start 


Hi James


Thanks for the input. Unfortunately, disabling EDT did not help. I made sure that the session uses TCP, but graphic errors still persist.


Also Latency got even worse with TCP, horrible performance...


Regards, Cedy

Link to comment
  • 0

So we went back to 7.15 CU4 VDA a few weeks ago, because there was another bug in VDA 1906 with session disconnections. With the older VDA, the graphics problems seemed to be solved with GRID 9.0 drivers. 


However, today I tested a VM with VDA 1906 to apply the hotfix for the disconnection problems. Then I recognized that the graphics issues still occur with VDA 1906 and GRID 9.0 drivers.


I just don't know how to solve it, since citrix and NVIDIA also could not provide any help yet...



Link to comment
  • 0



how much framebuffer is used when the error occurs ? Please monitor with GPU profiler. Is it the same with "Use videocodec for compression" -->"do not use" instead of H.264 with visually lossless ? Is it the same behaviour with visual quality set to "high", "Use videocodec for compression" -->"for the entire screen " and visually lossless not enabled ?




Link to comment
  • 0

Hi Ron


Thanks for your answer. 


Framebuffer Use is under 40% when the issue occurs. (Please see the screenshot).



The issue does not occur with "Use videocodec for compression" -> "do not use", but the performance is much worse with this setting.


Also the issue does not occur with Image quality set to "high" and ""Use videocodec for compression" -->"for the entire screen ", but here also the performance is bad.



Regards, Cedy

Link to comment
  • 0



so it seems to be related to YUV 4:4:4 (visually lossless) with hardware encode and maybe Microsoft DDAPI. Since VDA 1903 DDAPI is used for capturing instead of NVFBC. Maybe some sync issue here. If you enable visually lossless but disable hardware encode ( not a good stable framerate imho, but for testing okay ) does the issue happens as well? You just swapped out the T4 vs P4 and issue is gone with exact same settings (FullScreen, visually lossless and HW encode ?) Very strange. I'll try to figure out how to nail it down. Did you exclude the VMware Graphics Drivers from VMwareTools during install. I've seen numerous problems if it has been installed although another display driver (i.e. Nvidia) is active. Did you try with a
Q-Profile by any chance. Maybe the Quadro-Render path is different even in capture & encode. just want to track the problem down.



This is indeed

On 8/5/2019 at 9:49 AM, Baumgartner AG said:

Also the issue does not occur with Image quality set to "high" and ""Use videocodec for compression" -->"for the entire screen ", but here also the performance is bad.


This is very strange as well. Normally this is the most performant setting although graphics quality for text isn't ideal because of Chroma Subsampling (YUV 4:2:0). it delivers the most constant framerate even in high CPU/GPU load scenarios (set to 30fps here). 






Link to comment
  • 0

Hi Ron


Thanks for taking time for this. 


Yeah I know about the text quality issues with "High" setting, that's why we are using lossless. 


We have also tested with Q Profile, same issue. 


I tried with lossless and hardware encoding -> disabled. Surprisingly I was not able to reproduce the issue with those settings. But the performance is slightly worse with hardware encoding disabled. Especially in AutoCAD when moving the drawing around, performance is worse. 


I installed latest VMware tools on the Image, so I think that VMware Graphics drivers are installed. Is it enough to disable the VMware display adapter or do I have to uninstall the driver? Is it possible to only uninstall the graphics driver and leave the rest of VMware drivers installed?


Thanks and best regards, Cedy



Link to comment
  • 0
On 8/30/2019 at 7:10 PM, Hus Zekayi1709161251 said:

@Baumgartner AG Try to increase the Display memory limit



I have increased it from 65536 > 4194303 (no limit according to this)

I had graphical corruption that looked just like yours does, which is now completely gone.


Hope that helps.




Thanks for the input. 


I will give that a try. Anyway, we had alot of call conferences with NVIDIA and HPE the last few weeks. 


Turns out that there is definitly a problem with the YUV444 encoder in relation to the Tesla T4. We now use YUV420 and "build to lossless" as a workaround. With those settings, image quality gets reduced while moving pictures inside the VM, and lossless quality is shown when the image stays still. It's only a workaround for us and citrix is continuing their work in their lab to get this solved. 


May I ask you what your hardware and software specs are? Are you also using Tesla T4?


Thank you very much

Link to comment
  • 0
43 minutes ago, Baumgartner AG said:

Tried increasing the display memory limit, unfortunately it didn't help. 




We have 4 PCs running Win10 1809 - 3 of them have RTX 2080 Ti's and one of them has a GTX 1080 Ti.

Try using H265 encoding since all your GPUs are nvidia, instructions are here:

Also are you using Citrix Reciever on the client machine? if you are make sure you uninstall it and install Citrix Workspace instead:


Also make sure you haven't got GeForce Experience installed, one of our machines had that causing issues for us.


Hope that helps.

Link to comment
  • 0

Hi to all,

We  have the same problem.
We are switching from P40 to T4 using the same settings we used with the P40.
On the T4 we are only experiencing the problem with graphics using H265 (Registry Key on the Client with CWA). Without this key the graphics are very good but we would like to use the H265.
Citrix policies used:
Optimize for 3D worklod - Enabled
Use Hardware encoding for video codec - Enabled
Use Video codec for compression - For the entire screen
Visual Quality - High.

We use Catia V5

Is there a solution?

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...