Jump to content
Welcome to our new Citrix community!
  • 1

1903 VDA scripted update - Failing - workstation service won't start after reboot


Kent Bratt1709154576

Question

I am trying to upgrade a couple of our Dedicated Windows 10 VDA's via the AD startup Script, but it is failing. 

We have used this method for all the LTSR updates without issue.

 

It seems that we are having some issue going from 7.15.400 to 1903, and the issue seems to be around the "Citrix Pvs for VMs agent". 

After one of the reboots, the workstation service won't start because of a the service dependency on Citrix PVs for VMs Agent. That service won't start. 

We are using MCS to create the machines. 

 

If I remove the service dependency via the registry, I can then start the workstation service and can then again browse the network. 

To get it back in a good working order, I have to use the VDA Cleanup utility a couple times, then manually upgrade the VDA to 1903. 

 

Is anyone else seeing this or something similar? Is anyone upgrading their VDAs via the AD startup script? 

 

Link to comment

5 answers to this question

Recommended Posts

  • 1

Removing PvsVmAgent from DependOnService didnt help to fix the upgrade for me. 

I had even tried Removing the "Machine Identity service Agent" and "Citrix HDX WS x64" components before upgrade for VDA LTSR CU2 to CU3, nothing worked. its not 100%. some upgraded successfully many failed.

So i changed the approach a bit in the script to make it work as per my requirements. It worked!

 

1. Powershell script will create 2 schedule tasks in the target VDA

   1.1. first task will have the trigger action to start the upgrade at a predefined Time

   1.2. second task will start the existing VDA uninstall and reboot the VM

2. Post uninstall at the configured time, task will trigger the VDA installation of CU3

3. End of installation a reboot will be initiated

 

This works flawlessly for me instead of inplace upgrade. I use to do PSEXEC for these upgrades, but my security team has blocked execution of PSEXEC, so had to change the approach :)

 

Hope it helps 

  • Like 1
Link to comment
  • 0
On 6/12/2019 at 2:42 AM, Silvio Balduzzi1709153051 said:

Hi,

 

I think the only solution, in this case, is using the VDA Cleanup and not automatize the upgrade. I'm sorry.

The VDA upgrade has many problems and I don't recommend it.

 

Silvio

 

Thanks for the reply, but that sounds like an awful solution for customers with any substantial number of Dedicated VDAs. 

 

Agreed the VDA upgrade process has been less than optimal typically, still considering the AD script is provided as a documented solution by Citrix, I would expect it to be somewhat working. https://docs.citrix.com/en-us/citrix-virtual-apps-desktops/install-configure/vda-install-scripts.html   

 

May try working with the SCCM team next to see if I have any better luck there. 

 

Link to comment
  • 0

I've got the 1909 Update working via the AD Install script citrix provides. 

 

I had to modify the Script a little to get it to work for us, 

 

Right before it runs the VDA install, I added a line in the script that removes the PVSAgent from the LanmanWorkstation Service dependencies via registry

This allows the Workstation Service to start after a reboot which is obviously needed, then the Value is added back via the Install. 

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...