Jump to content
Welcome to our new Citrix community!

Web Interface must be manually refreshed to process logon/enumerate apps


Jason Fortun

Recommended Posts

I have an old CSG/WI5.4 system I need to keep around for a bit more time for reasons I won't go into.  This system processes logons from a federated service (Ping). Normally, the user clicks on the federated link from our non-citrix portal, they are redirected with the token to the web interface site, the site accepts the passed-on credential and enumerates apps.

 

Now- seemingly out of the blue- when a user clicks on the federated link the web interface site is launched and it just sits there at the WI site (with nothing showing on the screen).  If you hit f5 a few times to refresh the site, it does process the login and enumerates apps and apps launch normally. There are WI 3 sites hosted on the server. Both of the federated sites show the same behavior, the non-federated site word normally (the user logs on at the WI logon page).  There seem to be no errors in the eventlogs. Ultimately I know the answers is "retire that old thing" but I can't just yet. Any thoughts as to what might cause this odd behavior or any thoughts about a workaround?

 

Thanks!

Link to comment
Share on other sites

Some additional finds that might spark an idea:

 

1) I run 3 sites on the WI server. Partnerfed, enterprisefed and nonfed. The first two are federated against two different domain, the thirds is not federated at all.

2) If i run a repair against one of the fed sites BOTH sites then start working.

3) several hours later the refresh problem returns

 

any help would be appreciated

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...