Jump to content
Updated Privacy Statement
  • 0

Citrix Device Redirection - "Optimized, Policy Restricted"


Katrina Cruz

Question

Hi all,

 

I've looked through documentations and forum threads and couldn't figure out this one, hope someone can help me out here.

 

We have a Jabra Pro 930 headset and this is to be used by multiple call center support engineers within a Citrix session. The headset is compatible with Citrix according to this article here:

https://citrixready.citrix.com/jabra/jabra-pro-900-series.html

 

We're trying to get the device to show up in the "Jabra Direct" app (installed on the VDA):

 

image.thumb.png.6f08dafed10d0c1fb66d9f080d01c753.png

 

 

Aside from the above issue, the headset's microphone works just fine when tested inside the Citrix session at https://www.onlinemictest.com

 

 

 

To use a device in a Citrix session, it needs to be redirected. We are familiar with how device redirection works and have set this up for other devices in the past. First of all, here's the VID & PID of the Jabra headset:

 

image.png.cbbebba6a1fc23df119731af5126a9a8.png

 

And the class is 01:

 

image.png.8796946400ed1806e1b0480556ca59fc.png

 

 

Here's the policy configured on the DDC:

 

image.thumb.png.5aa32a2147d6a020606c99802f201b50.png

 

 

As you can see in the screenshot below, the VID & PID matches what is found under Device Management (screenshots above). However, it shows "Optimized, Policy Restricted" and we can't switch to generic virtual channel (full redirection). For my webcams, they can be switched to generic virtual channel and work just fine within the Citrix session:

 

image.thumb.png.4dd8ca032bc2bea1293245a2b80292fc.png

 

 

I have tried adding the "AutoRedirect" reg key here, as per this guide (see bottom of page) - https://docs.citrix.com/en-us/citrix-virtual-apps-desktops/policies/reference/ica-policy-settings/usb-devices-policy-settings.html

 

image.thumb.png.3b3366219d930940f92bf7a51fbf12b1.png

 

I've also tried this:

 

image.thumb.png.f94ee96f9356603f9415742a03e1752e.png

 

And also this:

 

image.thumb.png.c56e0a8cea1a21227c98496d69200481.png

 

 

And setting this group policy:

 

image.thumb.png.9744645558c86ee4683175d2a66ec3d0.png

 

 

We thought perhaps we need to split the device and redirect the HID device, so we've done this:

 

image.thumb.png.b9fa4c88432e0bbbb0fcbbf9fa6900ae.pngimage.thumb.png.c64ca14efdad741f7ea31db1986f7426.png

 

 

We can select/deselect the HID device, but we couldn't get it to show up in the Jabra Direct app. Not sure if this is an app issue or a HID redirection issue, or something else?

 

 

 

I have gone through the following guides/forum threads:

https://support.citrix.com/article/CTX137939

https://discussions.citrix.com/topic/372708-usb-redirection-restricted-by-policy/

https://discussions.citrix.com/topic/361179-redirect-usb-device-automatic-with-generic-instead-of-optimized/

https://support.citrix.com/article/CTX129558

https://support.citrix.com/article/CTX234916

https://support.citrix.com/article/CTX203592

https://docs.citrix.com/en-us/xenapp-and-xendesktop/7-15-ltsr/policies/reference/ica-policy-settings/usb-devices-policy-settings.html

https://support.citrix.com/article/CTX133024

https://discussions.citrix.com/topic/379174-usb-redirection-of-hid-devices/

https://docs.citrix.com/en-us/receiver/windows/4-9/configure/config-xdesktop/config-composite-usb-device-redirection.html

https://discussions.citrix.com/topic/372708-usb-redirection-restricted-by-policy/?csrfKey=

 

While we're not using Linux (we're using Windows), I think the following forum thread is a similar issue to ours:

https://discussions.citrix.com/topic/396851-headset-usb-generic-redirection-or-mapping-behaviour/

 

The Jabra headset device is indeed a USB Composite Device and setting the "Client Audio Redirection" and "Client Microphone Redirection" as Prohibited gave us the result of just "Policy Restricted" for the Jabra Device under Devices. However, the Redirect tickbox is disabled:

 

image.thumb.png.f0aade921cafdf62b860d5eed106d3b8.png

 

https://docs.citrix.com/en-us/receiver/windows/current-release/configure/config-xdesktop/config-composite-usb-device-redirection.html

 

 

image.png

Link to comment

10 answers to this question

Recommended Posts

  • 0

I to am having the same problem. But than using Jabra evolve 65 and 75 headsets.

 

Configuration for us so far:
Audio en microphone redirection turned off
USB redirection turned on

As soon as citrix workspace connects we can see the headset connection drop on the client computer.

 

But it never shows up in the citrix session. And because of that the headset isn't working, nor is jabra direct working.

 

So if anybody got a jabra headset to work correctly with jabra direct (or jabra express) any tips would be appreciated!

Link to comment
  • 0
On 10/2/2019 at 11:47 AM, Marco Krage said:

Have a look at https://support.citrix.com/article/CTX234916

On a Windows Client there is a registry key (HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Citrix\ICA Client\GenericUSB\DeviceRules) which denys some HDI Classes.

DeviceRules registry setting take precedent over Citrix policies in Studio, AD and Receiver.admx policies on the client computer.

Thanks for your answer! I tried this but unfortunately it didn't work.
For now I'm going to try to find somebody that can help me with this.

Link to comment
  • 0

Hi Katrina,

 

does your environment contain single- or multi-session OS machines? 

I am experiencing the same issue with a Logitech H800 headset (Optimized, policy restricted), but only in a multi-session (W2012, W2016) OS environment. In a single-session OS environment (W7), I am able to switch from optimized to generic and back. CTX policies concerning usb redirection are the same in both environments.

So it seems to have something to do with difference between desktop and server OS, perhaps RDSH policies. Haven't figured it out yet though...

 

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...