Jump to content
Welcome to our new Citrix community!
  • 1

Server 2016 Start Menu Inaccessible


Question

Running into a weird issue with Server 2016 and the Start Menu.  Running VDA 7.15.3 on Controller 7.15.3.

 

We can login once fine and everything works.  On the second logon we receive a black screen for about 4 minutes and the event log shows the following error:svchost (2860) TILEREPOSITORY<USER SID REMOVED>: An attempt to open the file "C:\Users\<USERNAME REMOVED>\AppData\Local\TileDataLayer\Database\EDB.chk" for read / write access failed with system error 1920 (0x00000780): "The file cannot be accessed by the system. ".  The open file operation will fail with error -1022 (0xfffffc02).

 

After the four minutes, we get our desktop and icons.  Once you click the start menu, it does nothing at all.  Everything else works except the start menu.  

 

I have seen the following article: https://support.citrix.com/article/CTX224835 and ensured that Usrclass.dat* and packages are excluded.  I have also added AppData\Local\TileDataLayer to folders to mirror and added: AppData\Local\TileDataLayer\Database\vedatamodel.edb to the excluded-files section.  

 

I have run through the James Rankin article: https://www.htguk.com/everything-you-wanted-to-know-about_23/ which has vedatamodel.edb in the Files to Sync instead of the Folders to Mirror with it Excluded and still have the same problem.  Any ideas would be greatly appreciated. 

 

Thanks

Link to comment

20 answers to this question

Recommended Posts

  • 0

Assuming you're using UPM, I've configured the Start Menu in our environment (same versions as yours) as per https://james-rankin.com/articles/management-of-start-menu-and-tiles-on-windows-10-and-server-2016-part-2/ which is a more recent article by James, and it has it configured the same as you're doing;  excluding the vedatamodel.edb file, and mirroring AppData\Local\TileDataLayer. I've configured that in the UPM section of WEM and it seems to be working for me. I almost went back to GPO for the UPM settings, as it seemed very hit and miss initially. Not sure why, but it's working 100% now. But the Start Menu is roaming OK with those settings. Are you using WEM perchance? I've had it not apply the UPM registry settings before it "settled down". Check HKLM\Software\Policies\Citrix\UserProfileManager to make sure the exclusions are there maybe?

Link to comment
  • 0

We also don't have WEM. The settings to exclude vedatamodel.edb and to mirror !ctxlocalappdata!\TileDataLayer are set like we are told in the UPM Best Practice Guide.

https://docs.citrix.com/en-us/profile-management/current-release/profile-management-best-practice.html

Also tried to exclude !ctx_localappdata!\Packages and !ctx_localappdata!\Microsoft\Windows\UsrClass.dat* but the problem still exists.

Link to comment
  • 0

the thing is, that we are also running App Layering and MCS at the customer with this problem.

We have an other customer running Windows Server 2016 VDA with MCS but without App Layering where we dont run into this issue.

I dont know how App Layering can affect UPM, but this is what I see.

I also upgraded ELM and the os tools to the latest version but the problem persists.

Maybe I can create an Masterimage without App Layering at the first customer and test it - I will keep you up-to-date.

Link to comment
  • 0

Hi. We're using App Layering and PVS. Add that to WEM, FSLogix (for Office 365 + 1 app container only, not profiles) and Nutanix AHV (moving away from ESX) and I was expecting lots more problems than we're having. WEM seems to be the bulk of my problems tbh, although like I said it's calmed down a bit. If you can wait till Monday (UK time) I will dig out my UPM config and post it here, but I'm pretty sure I'm not doing anything out of the ordinary. I also upgraded ELM to the latest version and no issues thus far. I assume you installed the VDA (along with UPM) in the platform layer. I can also dig out my spreadsheet that I use to keep track of my layers and what went where. The only thing I do different with UPM is I don't use the !ctx variables. I like to use the proper paths like AppData\Local. It makes no difference, but it's just a thing I do.

 

I'll post back on Monday with my UPM and App Layer setup.

 

Nick

Link to comment
  • 0

Quick update.  Running a basic image with just the platform, the OS, and no elastic features enabled worked fine.  I had previously tried with elastic enabled in the template but my end-user didn't have any elastic apps assigned at all. 

 

This at least tells me it is some way isolated to App Layering and not my UPM configuration.  I am going to publish my image with all my applications but with elastic apps disabled in the image template.  If this works, it tells me something is seriously broken in 1903 with elastic apps even when none are assigned to the end-users. 

Link to comment
  • 0

Apologies for not getting back; seems you don't need my UPM config now anyway.

 

We're not using elastic layering, so I've not run into that issue here. However, at a previous customer having elastic layering enabled in the template was causing issues (tbh I forget how the issues manifested themselves). From memory, and this was a while ago, I believe the fix in that instance was to remove any ghost NICs (see CTX221733) and then it worked with elastic layers enabled in the template. Not sure how that would affect UPM in your case. Might be worth checking though.

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...