Jump to content
Welcome to our new Citrix community!

Lost config on Netscaler VPX (Freemium)


Jon Yiesla

Recommended Posts

I've used the free version of the Netscaler VPX for years as a load balancing appliance and that's always worked OK.  I recently set up a new environment and got the latest version (12.0) of the Freemium version. According to what I can tell, I no longer need to get a license for this.  When I check the SYSTEM->LICENSES it shows that I have no license, but it shows I am licensed for Load Balancing, Content Switching and a few other things.

 

I'd completely gone thru the set up that I have on other VPX appliances and had it all configured and running. It's still in a test mode, so I've probably not tried to access this for some weeks. I went in today to try and connect to my system thru the VPX load balancing appliance and I'm unable to do so. After much troubleshooting I looked at the appliance and it appears that except for the basic assigning of the main IP, all of my configuration is gone.  Unfortunately I'd not made a backup. I can reconfigure it, but does anyone have an idea why this might have happened?

 

I also noticed that when I click on Load balancing it has a yellow exclamation mark and a pop up comes up in the lower right of the window that says load balancing features aren't enabled.  However, on the license page load balancing has a free check by it.

Link to comment
Share on other sites

I did discover by going into Settings and then, Configure basic features, that the check box for load balancing was unchecked. I checked it and now the yellow exclamation mark is gone... but I still have my original question...what might have wiped all of my settings?

Link to comment
Share on other sites

Hi,

If there is not a license and the config is saved in that state the config will be overwritten. The ADC keeps 5 revisions of the config that get overwritten sequentially as you save the config. The ADC also saves the config at every upgrade. the file name will contain the version the appliance was at the upgrade time. 

Login to the appliance and check the /flash/nsconfig directory. Find a good config and just batch it in after that. 

 

Val 

Link to comment
Share on other sites

  • 10 months later...

So, I had something similar happen again. We lost the ability to connect thru the VPX Appliance and when I checked, the config was completely gone again. Unlike last time, the Load Balancing piece had the yellow exclamation point and the basic IP addresses of the appliance were there, but everything that I'd set up as a part of the load balancer working was gone. We recovered a back that had been made of the virtual VPX appliance from a day or so ago, but it too was lacking the config. I know that after this happened last May, that I'd backed up the config and then downloaded it, but I couldn't find where I downloaded it to and the back up stored on the appliance was no where to be found. This is the Fremium version, so there's no license to go get and install.  What could possibly be causing this?  And, it "appears" that as of at least a couple of days ago, the config was missing as well.  How could the device continue to function if the config was missing as long as a couple of days ago?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...