Jump to content
Welcome to our new Citrix community!

netscaler adc 12.1 clientless access cvpn rewrite url


Recommended Posts

Hi,

 

We try to publish a internal web application with the clientless access feature of the citrix unified gateway.

When we try to access the web application from outside we are able to connect to the internal web application with CVPN.

 

The link he shows when i access the web application is as follows:

https://gw.gew.nl/cvpn/aHR0cHM6Ly9tb25hY28uc2Z2Zy5ubA/

 

However the page is not displayed correctly because the page needs to load additional files (javascript, css) into the page.

 

Additional files in the source code of the page:

<head>
 <TITLE>Monaco Portaal 10</TITLE>
  <meta name="robots" content="noindex, nofollow"/>
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8">
  <meta http-equiv="X-UA-Compatible" content="IE=edge"> 
  <meta http-equiv="Cache-control" content="no-cache">
  <meta charset="utf-8"/>  
  <link rel="stylesheet" href="../monaco/common/dx.common.css" type="text/css"/>
  <link rel="stylesheet" href="../monaco/common/styles.css" type="text/css"/>
  <link rel="stylesheet" href="../monaco/common/mnc.common.css" type="text/css"/>
  <link rel="stylesheet" href="../monaco/common/hover.css" type="text/css"/>
  <link rel="stylesheet" href="../monaco/common/flaticon.css" type="text/css">
  <link rel="stylesheet" href="../monaco/common/custom.css" type="text/css"/>
     <link rel="dx-theme" href="../monaco/common/dx.light.compact.css" data-active="true" />  
      <script src="../monaco/MonacoEncryptie.js"></script>
  <script src="../monaco/jquery-3.1.0.min.js"></script>
  <script src="../monaco/jquery-ui-1121.min.js"></script>
  <script src="../monaco/dx.all.js"></script>
  <script src="../monaco/underscore-1.5.1.min.js"></script>
  <script src="../monaco/js.js"></script>
  <script src="../monaco/moment-with-locales.min.js"></script> 
  <link rel=apple-touch-icon href=../monaco/Images/MONACO114x114bl.png>
  <link rel=apple-touch-icon-precomposed href=../monaco/Images/MONACO114x114bl.png>
  <link rel="shortcut icon" href="../monaco/Images/favicon.ico?v=1" type="image/x-icon"/>
<script type="text/JavaScript">

 

The page is not able to load the additional files into the page because the translation to the path of these file is wrong:

https://gw.gew.nl/cvpn/monaco/MonacoEncryptie.js (one example)

 

It works with:

https://gw.gew.nl/cvpn/aHR0cHM6Ly9tb25hY28uc2Z2Zy5ubA/monaco/MonacoEncryptie.js

 

I tried a couple things with responder policy but it didn't work out.

 

I hope someone can help me any further.

 

Regards,

Richard

 

Link to comment
Share on other sites

  • 1 month later...

 

We solved it another way with CVPN it didn't work at all.

Externally we created a DNS record pointing to the content switching vserver.

The content switching vserver has a content switching policy that every request send to that url (external DNS record) is forwarded to a non addressable lb vserver.

Before forwarding to the non addressable vserver the content switching server has form based authentication enabled with a aaa authentication profile.

The aaa authentication profile send every request to the unified gateway where the authentication takes place.

After authentication it wild send the user to the non addressable lb vserver backend server.

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...