Jump to content
Welcome to our new Citrix community!
  • 0

Launching Published App Triggers Remote Desktop Connection


Matt Meserve

Question

I'm running Citrix 7.18. I have two delivery groups (Remote Desktop & App Server) that are both using a single storefront.  I have published several apps from the app server and can access them from remote desktop through Citrix web and also have access to them on my local desktop through Citrix Workspace.  I have a couple of scenarios happening when I launch an app but can't figure out what's causing it.

 

Remote Desktop

When I log into the web storefront I can launch Remote Desktop and see my published apps in a folder on my desktop.  When I launch an app it causes Citrix to initiate a second Remote Desktop session within my current Remote Desktop session along with the app.  The app does open fine but in the background I've got a second Remote Desktop session partially launched and an Access Denied popup.  I click OK on the popup and the second Remote Desktop session disappears but the app remains open.  This only happens after launching the first app once I login to Remote Desktop.  If I launch other apps after they seem fine.

 

Local Computer

I have my Citrix Workspace on my local computer pointed to the storefront and can access my published apps folder on my desktop.  From here, when I launch an app, a remote desktop session opens instead of just the app.  Unlike launching the published app in Remote Desktop as mentioned above, I don't see an Access Denied popup.  The RD fully loads and I have to close it, leaving just the app open.

 

Each time this happens I'm seeing the following event on my Remote Desktop server:

Level: Warning

Source: rpm

Event ID: 7

ICA Connection request denied because the current user, [domain\username], is not the owner of the Session, [domain\username].

 

I have checked Studio as well as Task Manager on the RD and App servers prior to logging in and there are no existing/disconnected session for the user prior to login.  I have read that this error can be seen if you try to launch an app before the system has completed a previous task or login, which makes sense.  However that doesn't appear to be the scenario here.

 

Thanks for any assistance!

Matt

 

 

 

 

Link to comment

1 answer to this question

Recommended Posts

  • 1

Closing out this one.  This turned out to be a quirky issue with the ICA file.  While setting up this environment I've tried different configurations and, while everyting was setup correctly, the profile I was logging in as was opening published apps using the wrong ICA file.  I switched my receiver settings to put shortcuts on desktop instead of having the shortcuts in a desktop folder and all worked.

  • Like 1
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...