Jump to content
Welcome to our new Citrix community!

DNS Name Server: can't add Name Server into DNS Name Servers List


Recommended Posts

I am running Netscaler NS11.0: Build 64.34 and it seems like I have got a bug.

 

I am trying to add a Name Server to the DNS List and NetScaler seems to not be allowed to do that. I am running the following commands:

 

> show dns nameServer

1) company-dns - State: UP Protocol: UDP

2) 10.63.23.196 LOCAL - State: UP Protocol: UDP

DNS profile name: default-dns-profile Done

 

> add dns nameServer ibmcloud-dns

ERROR: Name servers already configured.

> rm dns nameServer ibmcloud-dns

ERROR: Name server does not exist.

 

ibmcloud-dns is a Virtual Service composed by a Service Group

 

I have already tried to reboot the NetScaler via warm-reboot and the same issue persists. I have already tried to run the > show runningConfig to find references to ibmcloud-dns:

add serviceGroup Ibm-cloud-dns-sg DNS -maxClient 0 -maxReq 0 -cip DISABLED -usip NO -useproxyport NO -cltTimeout 120 -svrTimeout 120 -CKA YES -TCPB NO -CMP NO -autoScale DNS

add lb vserver ibmcloud-dns DNS 0.0.0.0 0 -persistenceType NONE -cltTimeout 120 -dnsProfileName default-dns-profile

bind lb vserver ibmcloud-dns Ibm-cloud-dns-sg

 

This is a production HA environment and restarting is very limited; upgrading is a long term solution. 

Link to comment
Share on other sites

Hi this is expected, 

 

You can only use one entity for DNS and LB VIP or a server direct. Cannot use both at the same time as a DNS on the ADC itself. 

You can add the LB as the DNS server after removing existing DNS config. Alternatively you can remove the service group for DNS and add your servers as individual DNS servers. 

 

Val

  • Like 2
Link to comment
Share on other sites

Thanks Val,

 

    I was trying to do a Conditional Forwarder in Netscaler.

 

     Basically, after reading a few articles, I understood a little bit better how NS is working. If I add IP addresses, netscaler will round-robin the DNS and not recursively try to resolve through them.

 

    For this exercise, I have got 3 domains with different DNS Resolvers:

- netscaler.company.internal (Netscaler ADNS GSLB - Authoritative - Local)

- company.internal (Company DNS Resolver)

- cloud-endpoints.internal (Softlayer DNS Private Resolver)

 

    Company DNS Resolver -> Forwards -> Netscaler ADNS GSLB to resolve netscaler.company.internal. OK

    Company DNS Resolver don't have access to Soflayer DNS Private Resolver (and it shouldn't since it resolves Private IP Addresses in a Private Cloud, and Company can/should resolve public addresses)

 

     I was trying to make Netscaler redirect anything Cloud internal to a different DNS Resolver. (*.cloud-endpoints.internal to the proper Softlayer DNS Resolver). I am almost giving up since I can't find a good solution for this. If I add all the resolvers in the same LB, Netscaler does not try all them before giving the answer back as negative - I have already tried to mark the LB vService as recursive and non-cacheable, however, it has a non deterministic behaviour since sometimes it will pick the Softlayer DNS Resolver, and other times it will pick the Company DNS Resolver).

 

Regards.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...