Jump to content
Welcome to our new Citrix community!

Unable to join the storefront server to server group.


Recommended Posts

I am trying to add the second storefront server to server group. Servers are fresh install. StoreFront version is 1903.

I am getting the error  "The Process Does Not Possess the 'SeSecurityPrivilege' Privilege Which is Required for this Operation" While Running The Command 'New-DeliveryServicesCertificate'

There is an CTX article for the same error https://support.citrix.com/article/CTX221603 but it doesn't solve my issue.

Added the Local Administrators group as a member of the manage audit and security logs in GPO.

Group policy inheritance is disabled. I have also used domain admin account but I still get the error when trying to add the server to server group.

Interestingly I can create new deployment on the server which works fine without any issue. Problem is only when I try to add the server group.

 

Any suggestions ?

 

Link to comment
Share on other sites

I hope, NT SERVICE\CitrixConfigurationReplication and NT Service\CitrixClusterService accounts are included in the local Administrators group on the StoreFront server. (NT Service\CitrixClusterService will only show up once you initialize the Add Server process.). If not, please add it manually. 

 

If issue still not resolve, please follow the instructions stated in https://support.citrix.com/article/CTX207518 article

Link to comment
Share on other sites

I have followed the article CTX207518 but no luck.

On the second SF server I can see only NT Service\CitrixClusterService , I can not see NT SERVICE\CitrixConfigurationReplication account. I cannot add manually because the group is not there.

I have created a new VM without antivirus. StoreFront servers are moved to default OU where no group policies are in effect. Uninstalled the StoreFront from both servers and re-installed. Now when I try to add the SF to server group I get error. Following are the event errors

 

Event ID 8: Citrix Cluster Join Service

Exception attempting to remove failed Joiner configuration.

Citrix.DeliveryServices.PowerShell.Command.RunnerInterfaces.Exceptions.PowerShellExecutionException, Citrix.DeliveryServices.PowerShell.Command.RunnerInterfaces, Version=3.18.0.0, Culture=neutral, PublicKeyToken=e8b77d454fa2a856

An error occurred running the command: 'Remove-DSClusterEnvironment'

The term 'Set-DSAdminConsoleOperationMode' is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spelling of the name, or if a path was included, verify that the path is correct and try again.

At C:\Program Files\Citrix\Receiver StoreFront\Management\Cmdlets\ClusterConfigurationModule.psm1:1357 char:5

+ Set-DSAdminConsoleOperationMode -Mode "FirstUse"

 

Event ID 1: Citrix Cluster Join Service

Exception deploying Server Group.

Citrix.DeliveryServices.PowerShell.Command.RunnerInterfaces.Exceptions.PowerShellExecutionException, Citrix.DeliveryServices.PowerShell.Command.RunnerInterfaces, Version=3.18.0.0, Culture=neutral, PublicKeyToken=e8b77d454fa2a856

An error occurred running the command: 'Remove-DSClusterEnvironment'

The term 'Set-DSAdminConsoleOperationMode' is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spelling of the name, or if a path was included, verify that the path is correct and try again.

At C:\Program Files\Citrix\Receiver StoreFront\Management\Cmdlets\ClusterConfigurationModule.psm1:1357 char:5

+ Set-DSAdminConsoleOperationMode -Mode "FirstUse"

 

 

 

Link to comment
Share on other sites

The issue is resolved after performing the following steps. 

On both SF servers, uninstalled storefront component

 IIS - Application Pools - Removed all the Citrix Application pools.

Removed IIS role

deleted the Citrix folder in C:\ProgramFiles\ and deleted the inetpub folder in C drive. 

Removed all the registry entries related to "Citrix" manually. 

Restarted the Servers and re-installed storefront component. Server group created successfully. Propagation works just fine. 

 

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...