Jump to content
Welcome to our new Citrix community!
  • 0

Desktops not registering - Unregistered state


Question

Tried re-creating the image, reinstalling VDA and recreated the machines but it looks like it is not registering. Have done all the troubleshooting steps. I have done all the troubleshooting steps

 

I hate to go ahead and recreate a new desktop and install all the applications on it. So, I just want to fix this image itself somehow. Any suggestions. I have tried all these links.

 

https://support.citrix.com/article/CTX136668

https://www.carlstalhood.com/virtual-delivery-agent-vda-7-18/#registration
https://support.citrix.com/article/CTX117248
https://support.citrix.com/article/CTX227521

 

This one fully I did not try

https://www.carlstalhood.com/virtual-delivery-agent-vda-7-15-ltsr/#vdaport
 

I login to the streamed desktop and I see that there is no VDA installed. But VDA is installed in the master image and I create a master image, shut down and then I created another virtual machine. Removed the C drive, created template from the machine that had no C drive. This is what I am using to stream it. I logon to the streamed desktop and it shows no VDA.

 

Apps no VDA.JPG

Citrix Health Assistant.JPG

Edited by jfranci418
added images
Link to comment

4 answers to this question

Recommended Posts

  • 0
12 minutes ago, Carl Stalhood1709151912 said:

What Citrix Desktop Service error are you seeing in the Windows Log > Application log on the VDA machine?

Application log shows nothing much with Citrix 

 

But, the Windows log shows

 

The system failed to regsiter host (A or AAAA) resource records (RR) for network adapter with settings:

 

The IP addresses are listed (all DNS servers)

 

The reason the system could not register these RRs was because the DNS server contacted refused the update request. The reason for this might be (a) you are not allowed to update the specified DNS......blah blah

 

 

Error 1.JPG

Error 2.JPG

error 4.JPG

errror3.JPG

Link to comment
  • 0
On 5/10/2019 at 6:04 PM, Carl Stalhood1709151912 said:

What are those User Profile Service errors?

 

On the VDA machine, open Services, find Citrix Desktop Service and restart it. Then look in Event Viewer for events from Citrix Desktop Service.

There is no VDA installed on the streamed machine, so there is no Citrix desktop services to start it. Even though I have installed the virtual desktop agent (7.15 LTSR CU1) on the Windows 10 machine before converting it to a template and streaming it. But, I am suspicious as I built a vanilla image and recreated the steps by installing Target device, capturing the image and then shutting down the machine, removing the C drive and converting that to a template.

 

I then created virtual desktops from this template and still I see that the streamed virtual desktops do not have the VDA. I am confused how can this happen. Is it something with the Windows 10 Build 1809? or is it something in the steps that is being following that this happens? 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...