Jump to content
Updated Privacy Statement
  • 0

XenApp warning with only exclamation mark and name of app


Jeroen Proost

Question

Hello,

 

Yesterday I added three new applications in Citrix Studio, but when users try to launch them they only get a warning with an exclamation mark and the name of the app.  Other apps start without a problem. Strange thing is that only one user is able to launch the apps, but gets this warning when he launches a totally different app while other apps continue to launch flawlessly.
I compared properties between all the apps, tested with different Receivers and the new Citrix Workspace... but the issue still remains.

 

Anyone got any ideas ?

 

Thank you very much,

XenAppWarningOnlyExclMark.png

Link to comment

6 answers to this question

Recommended Posts

  • 0

Hi, anything inside the application logs (if any) or inside the event log (Server, DDC) ?
What version of XenApp ?
Well, don't think that this has to do something with Receiver/Workspace App version, since the provide the protocol to launch mainly. 
Does it launch when using an "Admin"-account,  or RDP ? 
You just provide apps, no desktop ?
Maybe post the post the application properties over here 
 

Link to comment
  • 0

Thank you FrankShifferstein1 for your quick reply. My apologies for not adding the answers to these questions in my original question.

 

In EventViewer I can see the following:
"Failed to launch application ... with command line '"C:\.....exe"' on client 'computername' for domain/user 'domain/user' in session '3'.   Ensure that the application is installed and that the user has permission to launch it."

and

"The Citrix ICA Transport Driver connection from IP:52993 to port 2598 received an invalid packet during its SSL handshake phase."
 

I added permissions to the .exe, but still no solution. Still strange though that the one user still has no problem launching these apps.

 

XenApp version 7.16, we only use published apps.

 

Admin account has no problem launching through Citrix Desktop and XenApp... so it has to do with rights, somewhere... But still... the other apps do launch for the users...

Yes, I checked "Limit Visibility". :-/

I can't test to launch the app through Citrix Desktop with a user account. Access and visibility to C:\ is disabled by group policy. I changed the policy and did a gpupdate, but I still can't see the drives on the "master server"...

Link to comment
  • 0

REGEDIT:

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]

"AppSetup"="CtxHide.exe,UsrLogon.cmd,cmstart.exe"

 

The setting for AppSetup when broken only has UsrLogon.cmd and needs to have CtxHide.exe before UsrLogon.cmd and cmstart.exe after UsrLogon.cmd

 

Launching applications worked immediately after adding these settings.

 

On a different system that works but is ruing 7.15 LTSR and Windows 2012 R2 instead of 1903 on Windows 2019 the setting for AppSetup was "UsrLogon.cmd,cmstart.exe"

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...