Jump to content
Welcome to our new Citrix community!
  • 0

Really long delay after clicking restart when building layers, specifically platform layer


Terry Rebstein

Question

I've been building platform layers and encountered this a few times at multiple customer deployments. When building a new platform layer (WEM, VDA, domain join, workspace app, NGEN) I want to do a few reboots prior to shutdown for finalize. I click restart but it takes me back to the login screen and just sits there for 20 minutes. I can see no major activity or processing and no clues as to what it's doing. Eventually it will restart.

 

I've also seen this happen when I click shutdown for finalize, it will log me off, but then sit at the windows logon screen for 20 minutes before it finally shuts down.

 

It seems to still work fine, but it's a little disconcerting to see this big delay with no real understanding why its not just rebooting or shutting down. Anyone else see this? Tips to avoid it?

Link to comment

9 answers to this question

Recommended Posts

  • 0

This is based on W2K16. It's quite strange as there's nothing running, I can actually log back in again and see task manager and it appears there's nothing happening. I'll try restart a number of times, even restart via the hypervisor (vmware) and then all of a sudden it will reboot or shutdown.

 

I don't see this on app layers typically I think it's platform layer only.

 

Thanks anyways

Link to comment
  • 0

Ok I had a chance to do some more testing. The Platform layer appears to be the only layer that suffers from this.

 

It doesn't seem related to the domain join as I am able to reboot successfully after that. At first i was leaning towards WEM, but now I'm thinking it's NGEN update related.

The sequence I tested is as follows:

  • Brand new platform layer
  • Join domain
  • Moved to App Layer Session Host OU
  • Restart OK
  • Logged in as domain user
  • Restart OK
  • Installed Workspace 1904 - enabled SSO
  • Restart - OK
  • Installed VDA 1903
  • Multiple reboots throughout install, all OK
  • VDA install finished - rebooted ok
  • Rebooted again, ok
  • gpupdate /force
  • Reboot Ok (multiple)
  • Deleted domain user profile
  • Rebooted ok
  • Installed WEM 1811 as local admin
  • Rebooted OK 
  • logged in as local admin
  • Rebooted OK
  • Ran NGEN update via batch file as admin. Completed successfully
  • C:\Windows\Microsoft.NET\Framework\v4.0.30319\ngen.exe update
    C:\Windows\Microsoft.NET\Framework64\v4.0.30319\ngen.exe update
    C:\Windows\Microsoft.NET\Framework\v2.0.50727\ngen.exe update
    C:\Windows\Microsoft.NET\Framework64\v2.0.50727\ngen.exe update
  • Tried to reboot after a minute, say restarting and just takes me back to logon screen (time and date). Eventually restarts
  • logged in again and tried a restart, 17 minutes later it restarted. (no load observed at all)
  • logged in again and shutdown for finalize, takes me back to logon screen 18 minutes later it shut down.

 

 

This is  super painful being so slow, as creating layers can take time and adding in artificial lengthy delays is not ideal. Any help or info is really appreciated! 

Link to comment
  • 0

Sorry Rob, just to clarify, what do you mean by 2.x versions? I'm running app layering 4.1903 with the .64 hotfix for UPM streaming. 

 

Do you mean on updated platform layers? What are the v4 updates?

 

I can skip NGEN in the platform layer but I don't think that's best practice.

 

Link to comment
  • 0

Hi trebste315,

 

this topic is a bit old by now, but were you able to fix that issue? We are currently experiencing the same...

Even when creating a new platform layer.

Running ngen.exe update did not help. 
What I noticed is, after triggering the restart, the login screen appears again (for up to 30 minutes) but if I log in again and then sign out, the restart happens straight away.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...