Jump to content
Welcome to our new Citrix community!
  • 0

XenServer 7.2 - NFS Netapp Connection problem


Keith Woodworth

Question

Xenserver 7.2, 3 hosts in a pool with HA on. SR is an NFS mounted Netapp. One part of the SR is for

ISO's and the other is VM storage.

 

Had one of the hosts drop with a memory error last night, when I connected to the DRAC and restarted

it manually as it was stuck it came up but wouln't come out of maint mode.

 

Had multiple consoles open to the Xenserver hosts and it was late and I realized I needed to disable HA.

I typed the command into the wrong window and the whole pool was left in a state and knocked down

host #3 into maint mode when I restarted the tool stack on the master.

 

Long story, after a long bit I managed to the get both of the hosts that were in maint mode, out as well as

disappearing IP/NICs on the console of both servers reappeared after I left everything for a bit as both hosts

kept saying they were still booting.

 

Eventually the NIC's came up, the bonded ports reattached but on the two Xenserver hosts the NFS SR will

not reattach.


The master is still attached to the NFS SR and as a precaution moved the most important VM's to local storage

on that machine.

 

I do notice that under the Networking Tab for the Xenserver hosts that are not attached to the SR the IP Address config for the two NIC's

that are bonded to the Netapp, have disappeared so will not repair.

 

The master of the pool is connected to the NFS store and can see the IP address config of the management and the netapp

NICs, but on the other two the Netapp link is missing from the IP Address Config.

 

How can I get that link to show up again for the two Xenserver hosts? How can I reattach that NFS store to those two

hosts?

 

Thanks,

Keith

 

 

 

 

Link to comment

6 answers to this question

Recommended Posts

  • 0

Hard to say without being there, but I think where you went wrong in my book is you don't do anything to 

a pool that has HA enabled until you disable HA. If HA is disabled now and the master is good restarting 

the slave hosts should get them in order. If you tried that and it doesn't know post and let us know.

 

--Alan--

 

 

Link to comment
  • 0

I left this for the last few days and let it just be stable the way it was before I started on this again this morning.

 

I just restarted one of the servers and it came up ok, except it is in Maintenance mode and when I try to exit it

manually xencenter says the server is still booting. I recall from Friday it did this but after about 30 mins it came out

of maintenance mode on its own. In the meantime, local storage on this machine is not accessible for some reason.

 

Oddly the console of this server via iDrac is not showing IP address's in the Status display, but on the xsconsole via

Xencenter on this same server I see the IP address info in the status and can see all the NICS.

 

Alan:

yes, where I went wrong was starting to do troubleshooting with HA enabled. When I realized I had to disable it I eneded

up issuing the HA disable command in the wrong window. I had multiple CLI windows open and

issued the HA disable command on server 2, not the master and I didn't realize until it was too late. I think that's when everything

started to go bad.

 

NTP is sync'd on all servers. I have multiple sources all the same across all three machines.

 

Once this machine comes out of maint mode I will see if I can manually mount the Netapp on it and I will try on the 3rd server

now as it is till up.

 

Thanks.

Keith

Link to comment
  • 0

Okay, hopefully you'll be okay with the restarts. Sometimes depending on the hardware XenServer doesn't show the 

ip address with XSConsole or its slow to update and show up. As long as you can get to it over the network with 

XenCenter thats the main thing.

 

--Alan--

 

Link to comment
  • 0

Was just about to begin with a new reply to update thread.

 

The restart would not reconnect the NFS mounts. I could not ping the Netapp from

either of the two servers. Management was good and worked and I could ssh to

the machines.

 

I ended up having to go into the networking tab and re-add the IP address of the

bonded ports that connect to the Netapp.

 

Once I did that, a repair was able to fix and mount the Netapp.

 

That appears to be the last part of it and things appear to be back to normal. I started a VM on

server 3 and the VM is good, running on the Netapp.

 

Just a word on the HA functionality, when server 2 had its memory problem and rebooted, the two production

VMs on that machine failed over to the master automatically and kept working. So HA did work as intended. (and

I had that setup correctly it appears for it to even work in the first place)

 

Thanks for the help. I'll be way more careful and remember to disable HA correctly when I need

to do anything again.

 

Keith
 

 

 

Link to comment
  • 0

Odd that you lost those IP addresses, but yes if your storage is on a separate network you need to have 

a management ip address for that subnet so you can communicate with it.  Adding that interfaces adds

to the routing table so you can get traffic to/from it.

 

--Alan--

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...