Jump to content
Welcome to our new Citrix community!
  • 0

Error trying to connect to Citrix Secure Mail


Question

I'm using an LG H520f, android v.5.0.2. When I log in to Citrix Secure Mail, you receive the following error message:

"We can not securely connect to the server. The server's certificate is not trusted."

 

Even if you format your smartphone, the error persists with any user attempting to open Secure Mail.

 

With that I can not connect.

Here we do not have Netscaler, our Endpoint is in the Citrix Cloud.

Link to comment

2 answers to this question

Recommended Posts

  • 0
10 hours ago, Wesley Porto Rodrigues said:

I'm using an LG H520f, android v.5.0.2. When I log in to Citrix Secure Mail, you receive the following error message:

"We can not securely connect to the server. The server's certificate is not trusted."

 

Even if you format your smartphone, the error persists with any user attempting to open Secure Mail.

 

With that I can not connect.

Here we do not have Netscaler, our Endpoint is in the Citrix Cloud.

Hope your Exchange server in On-prem and accessible via public network. It seems the issue is with your AD server. Can you please  check your server certificates? Meanwhile to workaround, you can enable the following secure mail policy and give it a try "Accept All SSL Certificates".

Link to comment
  • 0
12 hours ago, Wesley Porto Rodrigues said:

I'm using an LG H520f, android v.5.0.2. When I log in to Citrix Secure Mail, you receive the following error message:

"We can not securely connect to the server. The server's certificate is not trusted."

 

Even if you format your smartphone, the error persists with any user attempting to open Secure Mail.

 

With that I can not connect.

Here we do not have Netscaler, our Endpoint is in the Citrix Cloud.

 

Hi,

 

As my previous colleague wrote, one possibility would be to simply accept all SSL certificates.

You can do this via the mdx policys of Securemail.

I don't know much about cloud installations from Xenmobile. But I think the following could help.

 

Try to push your internal Root CA and the Intermediate via XenMobile to the Android device.

There is a policy that allows you to install certificates on your device.

 

Once you have installed the correct certificates, the setting "Accept all SSL certificates" should no longer be necessary.

 

kind regards

Alex

 

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...