Jump to content
Welcome to our new Citrix community!
  • 5

Server 2019 reconnect issues still around with 1903.


Jeff Riechers

Question

Has anyone else still seeing reconnect issues with Server 2019 published desktops?

 

When desktop gets disconnected due to timeouts, or machine sleep I can't reconnect until I do the "restart" option via storefront.  All connections are via TCP (UDP still broken) NetScaler Gateway VPX(sorry ADC marketing team) on the latest versions.  

 

When attempting to login the following lines are shown on the VDA.

 

The Citrix ICA Transport Driver has received a connect request from NetscalerSNIP:34495

 

followed by

 

The Citrix ICA Transport Driver connection from NetScalerSNIP:34495 has been closed.

 

Reseting the session on the NetScaler doesn't fix it.

 

Problem does not occur on Windows 10 1809.

Link to comment

Recommended Posts

  • 6

I can confirm issue with Reconnect (Windows server 2019/1912 LTSR CU1/CU2) is resolved for me after adding below registry

 

1. AutoEndTasks set 1 for force closing Apps like Notepad, word, etc...which are not saved. causing signoff/shutdown/restart issues (HKEY_USERS\.DEFAULT\Control Panel\Desktop" -Type String -Name "AutoEndTasks" -Value 1)

 

2.Adding a set of Process list (system/Application/AV including winlogon.exe,csrss.exe,dwm and LogonUI.exe, etc...) to LogoffCheckSysModules key. After trying many many combinations, finally graceful logoff worked by adding csrss.exe in the list (HKLM:\SYSTEM\CurrentControlSet\Control\Citrix\wfshell\TWI\LogoffCheckSysModules)

 

3.Adding same set of process ((system/Application/AV including winlogon.exe,csrss.exe,dwm and LogonUI.exe, etc...)) in the Sysprocs key (HKLM:\SYSTEM\CurrentControlSet\Control\Terminal Server\Sysprocs)

 

4.Previously i had the these 2 entries added as well, 

HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\Reconnect - FastReconnect=0

HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\Reconnect  - DisableGPCalculation=1

 

This infact helped resolve my log pending issue with pending logoff session.. .

  • Like 6
Link to comment
  • 2

Hi Guys, 

I just had an remote session with an engineer on my Case.

 

I'm currently testing another RegKey in addition to the Fast Reconnect Key mentioned before (which didn't change anything for me)

 

HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\Reconnect 
Name: DisableGPCalculation 
Type: REG_DWORD 
Data: 1 

 

(https://support.citrix.com/article/CTX207524)

 

He also told me that they had this issues with older versions before which were fixed but now they returned with Server 2019.

 

Maybe we can force them to fix it in the next CUs by all of us opening a case and refer to this Post showing them there are many customers having this Problem. So did i =) 

 

I'll keep u updated if i get any new results!

  • Like 2
Link to comment
  • 1

I am seeing similar issue with windows server 2019 and CVAD 1912 LTSR CU1. Issue is related to session going to hung state when user was working, at the end, in studio i can see session state a disconnected for indefinite hours. In my case the only way to clear out the hung session state is by restarting the server itself, logging off the session from director or killing the process from task manager within the server didnt help. 

 

All the symptoms of the issue pointed to https://www.mycugc.org/blogs/brandon-mitchell1/2019/09/22/not-so-fast-reconnect#:~:text=Balaji M-,Windows Server 2019%2C Citrix VDA and the,%2C Not-so-Fast Reconnect&text=Fast Reconnect%2C introduced with Windows,to a disconnected remote session.

 

but the fix of setting FastReconnect to 0 didnt help me for the issue. even after the registry fix, I am seeing the issue. As a temporary workaround, we have set bi-weekly Multisession Restart schedule till we fix the issue. The other work around is to hide the session which are hung or unable to logoff ($hidden parameter from $false to $true). By this way users will be able to connect to other available Multisession VDA apart from the one they have hung session available. I am having disconnect policy of 90 mins, My query pulls session that are more than 90 mins, which are hung sessions in my case.

 

Env info:

 

CVAD LTSR CU1

VDA 1912 LTSR CU1

Nutanix AHV

VDA OS windows server 2019

  • Like 1
Link to comment
  • 0
On 4/30/2019 at 1:33 PM, Kasper Johansen1709159522 said:

I am running a VPX 1000 in Hyper-V, it's an older version, but still supporting both EDT and DTLS.

 

That might be it.  This is my day one lab where everything is on the latest greatest.  12.1 is where I started seeing these disconnects.  You can see multiple EDT UDP sessions get created when users have the pausing grey screen.  I think for the longest sessions I had like 20 there.  I have yet to test with 1903.  It's on the to do list.

Link to comment
  • 0

We are experiencing the exact same thing in our environment ever since trialing 1811 and 1903 on Windows server 2019,

If we manually disconnect a session it can be reconnected to no problem, the session enters a 'broken' state after 2 hours of being idle.

 

Session is still listed as disconnected on the server however any attempt to reconnect to said session doesn't work. all you get is the desktop viewer window appear that starts the connection process and then that disappears after a few seconds. server logs two events exactly the same as the OP stated.

 

any advice on potential avenues here would be great

 

 

Link to comment
  • 0

I'm having the same issue with Windows Server 2019, I can manually disconnect/reconnect but unable to reconnect to a disconnected session.  I'm not using NetScaler.  I've built a bare minimum VDI, fully patched nothing else installed but the 1903 VDA.  I'm not having the issue with RDP session, ICA only.

Link to comment
  • 0

We've also tried the 1906.2 update but sadly no change, Still sessions that have been disconnected for about an hour dont reconnect. (desktop viewer just flashes up without reconnecting to session)

 

We also tried the advised fix that citrix posted but this yields  the same results, but by presenting a grey screen rather than no screen. The session on the server still displays as disconnected while grey screen is presented.

 

https://support.citrix.com/article/CTX256900

 

tdica 1007 & 1004 Event logs are also present on the VDA in quick succession, It seems the reconnect is attempted but never established.

 

 

Link to comment
  • 0

Although we weren't able to identify the exact issue we have been able to fix the issue by running through all of the suggested fixes:

 

- Install VDA 1906.2 

- Add the Fast Reconnect Reg ([HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\Reconnect "FastReconnect"=dword:00000000)

- Fully Patch Server (time of fix was up to October 2019 CU I believe)

 

After all of the above are in place we have stopped seeing any form of reconnect issue (disconnect or grey screen)

 

Not sure if its related but we are also using FSLogix VHD Profiles over UPM now.

 

Hope this helps everyone

Link to comment
  • 0
5 minutes ago, Evgeny Korolev said:

For me "FastReconnect"=dword:00000000 not helped. Disconnected session hangs as soon as I connect to it.

 

This was what we found too, untill we patched the server and updated the VDA too.

The reg fix alone just changed our issue from the reconnect just dropping connection to opening a desktop viewer with a grey screen

Link to comment
  • 0

Hi again,

so i updated to 1912 CU2 but the Problem perisists.. Our Users get stuck in a black, grey  or windows 2019 disconnect screen very often but not always.. Also when users get disconnected they end up in not beeing able to reconnect to their session...  we just disabled our 15 min autodisconnection for idle sessions to reduce the Users issues but by manually disconnecting some users still get this error. 

 

Setting FastReconnect to 0 did not change anything in my case. 

 

I'm also having a case with support - please update me if you guys found anything :2_grimacing:

Link to comment
  • 0

we're building a new Windows 2019 server image based on FSlogix profile containers and 1912CU2.  We are also seeing a problem with users attempting to reconnect to a disconnect session after a period of hours.  The launch attempt starts but then just disappears immediately.    The logs show the ICA open and then closed the connection on the VDA.  Logging off the disconnected session in Studio, then allows the user to log back on.

 

I'm going to set some idle and disconnect timeouts to see if its less of an issue when the session is logged off after a couple hours of being disconnected.  I'll open a case too

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...