Jump to content
Welcome to our new Citrix community!
  • 0

VDA 1903.1 commandline with MDT fails


MArkus Wehr

Question

Hi

 

I install the VDA with MDT. This worked until version 1903.

BCR_x64.msi now fails.

 

>>Product: Citrix Browser Content Redirection -- Error 1920. Service 'Citrix HDX Browser Redirection Service' (CtxBrowserSvc) failed to start.  Verify that you have sufficient privileges to start system services.<<

 

It works when I run the same commandline manually from same user (local administrator).

The problem seems to relate to the way MDT task sequenc calls the commandline.

Any ideas?

 

best regards

Markus
 

Link to comment

5 answers to this question

Recommended Posts

Hi Manoj,

 

here is the complete msi log file.

 

The XenDesktop Installation fails with errorcode 4 (error and reboot needed).

Form the Xendestop LogFile: "Citrix Browser Content Redirection konnte nicht installiert werden, mit internem Fehlercode 1920, fehlgeschlagene Aktion war 'StartServices'" - Error 1920 with StartServices.

 

I install Vc++ Redistributables 2013 and 2017 x86 and x64 in the step before  - then reboot- and afterwards run the VDA command line install.

 

best regards

 

Markus

 

 

 

BCR_x64437773279.txt

Link to comment

Thanks Markus for providing the log file.

 

I am investigating a similar issue. Can you please see if the steps in the below discussions, fix install issue?

https://discussions.citrix.com/topic/400623-1811-fresh-install-of-vda-stop-with-error-1603-browser-redirection-cannot-installed/

https://discussions.citrix.com/topic/401876-installing-vda-1811-on-win10-n-education-error-1603/

 

Best,

Manoj

Link to comment

Thank you Manoj,

ok I will see what I can do. If I compare my 1808 and 1903 installs i see these two differences:  1903 uses bcr.msi 1808 not.  1808 does not use "NT Autorität" for the service.

 

However my MDT task sequence does not sucessfully run the VDA command line install instead a manual call of the same command returns succesfully installing the service with the "NT Autorität" as shown in the picture.

My Workaround Idea: Try to install the VDA 1903 without bcr.msi and afterwards the msi from a commandline.  Ive had problems with one  warpped installer (paint.NET) before leading to the workaround to call from local administrator - autostart.

 

best regards

Markus

 

the image without print manager service = 1808 the other one = 1903

 

1808.png

1903.PNG

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...