Jump to content
Welcome to our new Citrix community!
  • 0

OneDrive Per-Machine issues in Win10 1809 + VDA 7.15CU3


Blair Williams

Question

Has anybody tried out the OneDrive per-machine install now that it's available from Microsoft? I've been testing it (currently version 19.043.0304.0006) on a Win10 1809 Enterprise desktop OS VDA, with XD 7.15 CU3, and I'm having a number of issues when I have the Files On-Demand option enabled. With that option turned off, the app works as expected, but it syncs the entirety of a user's OneDrive into their profile which I don't want to deal with right now. When I turn on the Files On-Demand option instead (either inside Settings or via the OneDrive group policy makes no difference), explorer hangs when you try to open a file from your OneDrive folder and explorer crashes if you try to exit OneDrive. Sometimes explorer just crashes when you first log in and OneDrive loads.

 

I cannot repeat the issue on a vanilla Win10 1809 machine that doesn't have the VDA installed, but I spun up a fresh Win10 1809 install, installed VDA 7.15 CU3, and ran the Citrix Optimizer with 1809 template, and the issue immediately presented, so I think it's either the VDA or something in the Optimizer template conflicting with OneDrive. I tried a few different OneDrive versions including the older per-user installs and they also have the problem when Files On-Demand is enabled so it's not looking like a version-specific issue on the OneDrive side.

 

I've been searching and not found another soul who has reported these issues either on technet or here. Am I special or just the first unlucky sap to report the issue?

Link to comment

1 answer to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...