Jump to content
Welcome to our new Citrix community!
  • 0

Xenapp 7.15 double hop drive mapping and RDP published app


Enrico Corvino

Question

Xenapp 7.15

client drive mapping works fine with standard application, example if user starts Excel published app, can open drives on his local workstation.

If users starts RDP published app, could not open any remote drive.

 

I've added a regkey on VDA server:

HKLM\SOFTWARE\Wow6432Node\Citrix\ICA Client\Engine\Configuration\Advanced\Modules\ClientDrive\NativeDriveMapping

 

setting it True or False then situation changed to this:

If users starts RDP published app, could open drives on VDA server which started RDP session, not drives on hos local workstation.

 

any suggestions?

Link to comment

9 answers to this question

Recommended Posts

  • 0

Check out this article: https://support.citrix.com/article/CTX137342

 

Symptoms or Error

A published Microsoft RDP client when used to connect to another Server or Workstation does not carry through XenApp local client drives.

Solution

Ensure that the server or workstation the RDP client is trying to connect has client drive mapping enabled directly on the RDP-TCP port or through a Microsoft Policy. For example if you are using the RDP client to connect to a Windows 2008 R2 server check the following:

Goto the Admin tool> Remote Desktop Session Host Configuration utility.

In the Properties of the RDP-TCP port,selectClient Settings tab.

In the Redirection tab, ensure the Drive checkbox is unchecked. If this check box is checked, it will disable drive mapping for RDP.

Note: If these settings are grayed out and not configurable, then Microsoft GPO might be enabled (see Microsoft policy location) or permissions to change this is not available. If this is the case, ensure to login as an administrator.

The Microsoft policy is located at Computer > Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Device and Resource Redirection.

Ensure that the policy is NOT Enabled and NOT set to Do not allow drive redirection.

Link to comment
  • 0
1 hour ago, Frank Nicosia1709160532 said:

Check out this article: https://support.citrix.com/article/CTX137342

 

Symptoms or Error

A published Microsoft RDP client when used to connect to another Server or Workstation does not carry through XenApp local client drives.

Solution

Ensure that the server or workstation the RDP client is trying to connect has client drive mapping enabled directly on the RDP-TCP port or through a Microsoft Policy. For example if you are using the RDP client to connect to a Windows 2008 R2 server check the following:

Goto the Admin tool> Remote Desktop Session Host Configuration utility.

In the Properties of the RDP-TCP port,selectClient Settings tab.

In the Redirection tab, ensure the Drive checkbox is unchecked. If this check box is checked, it will disable drive mapping for RDP.

Note: If these settings are grayed out and not configurable, then Microsoft GPO might be enabled (see Microsoft policy location) or permissions to change this is not available. If this is the case, ensure to login as an administrator.

The Microsoft policy is located at Computer > Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Device and Resource Redirection.

Ensure that the policy is NOT Enabled and NOT set to Do not allow drive redirection.

Indeed, this does make sense. NativeDriveMapping is an ICA technology, so it only "works" for ICA-in-ICA sessions. RDP sessions are completely other beast

Link to comment
  • 0
1 hour ago, Frank Nicosia1709160532 said:

Check out this article: https://support.citrix.com/article/CTX137342

 

Symptoms or Error

A published Microsoft RDP client when used to connect to another Server or Workstation does not carry through XenApp local client drives.

Solution

Ensure that the server or workstation the RDP client is trying to connect has client drive mapping enabled directly on the RDP-TCP port or through a Microsoft Policy. For example if you are using the RDP client to connect to a Windows 2008 R2 server check the following:

Goto the Admin tool> Remote Desktop Session Host Configuration utility.

In the Properties of the RDP-TCP port,selectClient Settings tab.

In the Redirection tab, ensure the Drive checkbox is unchecked. If this check box is checked, it will disable drive mapping for RDP.

Note: If these settings are grayed out and not configurable, then Microsoft GPO might be enabled (see Microsoft policy location) or permissions to change this is not available. If this is the case, ensure to login as an administrator.

The Microsoft policy is located at Computer > Administrative Templates > Windows Components > Remote Desktop Services > Remote Desktop Session Host > Device and Resource Redirection.

Ensure that the policy is NOT Enabled and NOT set to Do not allow drive redirection.

 

even if I'm using win 2016 server, I've checked and that policy is not enabled, in fact drive redirection works, but not the double hop of drive redirection.

Currently drives are mapped from VDA server which starts the rdp connection, not from the client which starts the ICA connection

Link to comment
  • 0
11 minutes ago, BART JACOBS1709152229 said:

Indeed, this does make sense. NativeDriveMapping is an ICA technology, so it only "works" for ICA-in-ICA sessions. RDP sessions are completely other beast

 

probably you are right, but the double hop drive redirection worked fine in previous farm Xenapp 6.5, so I'm wondering why it doesn't works on 7.15

Link to comment
  • 0
6 hours ago, BART JACOBS1709152229 said:

Maybe it's not a matter of XenApp version, but RDP client version?

 

 I've made some further tests, it's not related to RDP version cause doing RDP connections trough another RDP connections using old XA 6.5 server give same results, only VDA server drives are mapped.

Instead making and RDP connection trough ICA on old XA 6.5 farm allow to map client drives as you can see in the attached image.

x1hsviQOnZ.png

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...