Jump to content
Welcome to our new Citrix community!
  • 0

Citrix RemotePC Black Screen / not connecting


sdreiling2

Question

Hello,

 

we currently have a project with many 3D workstations on which users connect via Citrix RemotePC. On some workstations we have the problem that the user sees this black screen when connecting and nothing else happens. In Citrix Studio the user name is not displayed, only "-" is shown. Access via RDP works without problems. After a restart of the workstation the user can connect again without problems.
Does anyone know a solution? We already tried several VDA-Versions, including LTSR and the latest.

 

 

Thanks in advance,

Sebastian


remotepc02.thumb.png.7e3a016987f239852dd6f6be4a23309b.pngremotepc01.thumb.png.80d1fa4efed650d6b40bb42b9e326873.png

Link to comment

8 answers to this question

Recommended Posts

  • 0

- Make sure you are using the latest workspace app on the endpoint you are using to connect.

- Ensure you don't have Legacy Graphics Mode enabled in Citrix Policy.

- See https://support.citrix.com/article/CTX217194

In my experience on the VDA. Backing up the registry then deleting "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers\Configuration" and "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers\Connectivity" was all that was required. Restart (They'll re-create). However, i've linked the article in case you need to do the other steps mentioned.

 

Cheers

Justin

Link to comment
  • 0

OK thanks, we will give it a try.

We use the latest LTSR-Receiver because we didn't make good experiences with the workspace receiver, neither other receiver versions.

 

Next bug is that the start-menu is not responding when connecting to a machine. Sometimes it takes like 1-2 minutes until it is working.

I don't know if it is a bug with VDAs - we had it also on several terminal servers + non persistant VDI's. The easiest way was to use classic shell.

Link to comment
  • 0
  1. If LTSR has already updated then try to change the invalid mfapphook value in the following location.
  2. Below are the steps to modify the following regkey. (Ensure that first you may take the registry backup)
  • Navigate to regedit and Locate to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Windows
  • Entry type: String and Entry Name: AppInit_DLLs

image.png.308665ade3579e407d7d75edaed91697.png

 

  • You may see that on above screenshot that Value data is presently set with full path.
  • So change the Value: mfaphook64.dll, instead of giving the path name (See the screenshot below)

image.png.b8ad0324ed88af82caf7ce07ec61ce17.png

 

  • This will fix the issue.

Regards,

Akshay

Citrix VDI expert

 

Link to comment
  • 0

Hi Akshay,

 

thanks for the reply.

Unfortunately that didn't make any difference. There wasn't even an initial value in that String.

With one Client we could fix it (it works at the moment) by installing VDA 7-15-4000.

 

With another machine a user gets a black screen just on one of two monitors. It seems like there are some driver/ edid problems. But I think that is another bug.

Link to comment
  • 0

Hi Guys,

 

at the moment we have a cloud lab and we need to use the latest VDA.

We can reproduce the behaviour with this display bug (We publish Hardware Workstations with nVidia graphic cards (RemotePC)):

First login seems to be OK, reconnecting to the machine and you will get the Displaybug.

After rebooting the machine everything is ok (until reconnecting).

 

I found the solution here:

https://support.citrix.com/article/CTX237608

 

Policies here, but they don't influence thisissue:

https://support.citrix.com/article/CTX253834

Link to comment
  • 0

Hello Sebastian, 

we have exactly the same problem with: VDA1912 + Physical Windows 10 (19009) incl. nVidia Quadro P1000

 

First Login = Working

Secound login = Black Screen -> 4:3

 

CTX article did not work for me if I did everything correct.

 

I tried to give nVidia higher preference = Black Screen

I tried to give CitrixDD higher preference = Black Screen

 

 

Questions:

1. Did the "AdapterMerits" key exist in your setup?

2. Did you put higher preference on nVidia or CitrixDD?

regards
Mario

 

############

 

EDIT:

Just wrote one of the keys wrong......

Working fine now, thank you!

Edited by gbaier
Link to comment
  • 0

Hi Mario,

 

we used the default values decribed in this article.

 

Also we set the following Regkeys:

 

HKLM\SOFTWARE\Citrix\HDX3D\BitmapRemotingConfig

DWORD: HKLM_DisableMontereyFBCOnInit = 1

 

There was a bug in the past (see https://docs.citrix.com/en-us/xenapp-and-xendesktop/7-15-ltsr/whats-new/cumulative-update-1/fixed-issues.html - "

Session/Connection") [maybe this is fixed alredy - we still push this setting via Ivanti)

 

Did you set these policies?:

https://support.citrix.com/article/CTX253834

 

 

Additionally you may set this key on the Users machine:

https://docs.citrix.com/en-us/receiver/windows/current-release/improve/h-265-video-encoding.html

 

 

+ we don't install the complete nvdia-stuff, just the driver.

for nvidia silent setup leave only these folders: "Display.Driver","NGX.Core","NVI2"

"%~dp0setup.exe" -s -noreboot -clean

 

Install order:

> clean nvdia drivers and current vda installation

> install nvidia driver

> install vda (we use the core package)

 

start /wait %~dp01912_VDAWorkstationCoreSetup.exe /quiet /controllers "XXXX YYYY ZZZ" /disableexperiencemetrics /enable_framehawk_port /enable_hdx_ports /enable_hdx_udp_ports /enable_remote_assistance /enable_real_time_transport

 

I hope this helps.

 

 

 

Regards,

Sebastian

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...