Jump to content
Welcome to our new Citrix community!
  • 0

XENAPP 7.x VDA USING OWN 80 PORT TO COMMUNICATE TO DDC


Indranil Dutta

Question

One of our XenApp VDA Client using its own 80 Port to register over DDC Port.

By Checking the command (( netstat -a -b | findstr 80 )).. Our VDA using its 80 Port to register to DDC, Our environment has two DDC, Using its using own 80 Port to register over to DDC random 50K upwards ports as established.

 

Earlier, there was issue with Port conflict, but application using 80 port to listen is stopped now.

image.thumb.png.67fc33000e4c0cdace9c0760191dabff.png

 

Checked in HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\VirtualDesktopAgent, DDC is mentioned along with ControllerRegistrarPort is 80.

 

Please advise how to fix this issue.

Link to comment

5 answers to this question

Recommended Posts

Hiya

what do you mean by "own port 80" ? 

So the duplication is gone now and VDA not registering still ?
Well, you can check here https://support.citrix.com/article/CTX126992 , https://support.citrix.com/article/CTX117449, https://support.citrix.com/article/CTX207624
From my very own experience, most issues might be gone removing the VDA from Delivery Group and Maschine Calalog  temporarily add them again after.

Link to comment
14 minutes ago, Carl Stalhood1709151912 said:

You can change the port number that VDAs use for registration - https://www.carlstalhood.com/virtual-delivery-agent-vda-1903/#vdaport

 

Our Environement, DDC uses 80 Port to register the VDA.

Basically, we see VDA agents are communicating in two ports with Delivery Controller.. We have two DDC, So, total 4 Communications.

 

 

One side, we see our VDA using Own random port more than 50K to Comminicate with both DDC 80 Port.

also, we see another channel of same both DDC communicating with random port more than 50K to Communicate with our VDA Client own Port 80.

 

This is only happening with One VDA, other VDA are working fine.

 

So, how can i remove the VDA using its own 80 port to register to DDC random port and keep the other one.

Link to comment
16 minutes ago, Carl Stalhood1709151912 said:

Follow my article. You change the VDAs to a different port. Then you change the Broker Service to use the same port.

 

Registration is bidirectional so you have to change both sides.

I checked fautled server and working server.... the settings below is same for both

 

image.thumb.png.19f4230f3601491eab6520d4607d58fb.png

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...