Jump to content
Welcome to our new Citrix community!
  • 0

Ctrl key on client device keyboard not being mapped to LVDA session ??


John Salvo

Question

Client Device:

  • Windows 10 
  • Citrix Receiver 4.12

 

VDI sessions:

  • LVDA 19.03 with RHEL 7.6 in VMWare
  • Windows VDA with Windows 7 in VMWare

 

I am connected to two VDI sessions ( One LVDA, one Windows VDA ) from the Windows 10 / Citrix Receiver 4.12

Both VDI sessions launched from storefront.

 

There are two Ctrl keys .. One on the left and another on the right.

 

It seems that any Ctrl key combination that I do with the LEFT Ctrl key IS NOT being mapped / passed to the LVDA session. ( e.g. Ctrl-C, etc ).

However, all Ctrl key combinations that I do with the LEFT Ctrl key IS being mapped / passed to the Windows VDA session. ( e.g. Ctrl-C, etc ).

 

Thus, it is not a hardware / keyboard malfunction issue. I even tried a different keyboard just to be sure and I got the same result.

 

All Ctrl key combinations that I do with the RIGHT Ctrl key IS being mapped / passed to both the LVDA session and the Windows VDA session.

 

Anyone else experiencing this issue ?

 

Note that if my client device is Ubuntu with Citrix Workspace App 19.03 ...  instead of Citrix Receiver 4.12 ... the above issue does not occur.

 

 

Link to comment

2 answers to this question

Recommended Posts

1 hour ago, Jigao Huang said:

Issue can't be reproduced with the same environment.

 

It does not appear to happen straight away ... but it seems to happen over time.

 

It seems that, if I disconnect ( not Logout ) from an LVDA session, and then connect back to it via storefront the next day, then it happens. Let me confirm this by doing a few experiments.

 

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...