Jump to content
Welcome to our new Citrix community!
  • 0

Missing lock and power-off buttons in RHEL 7.5 / 7.6 ??


John Salvo

Question

Thought I should ask in here in case it was LVDA that was causing it. Anyone running LVDA 18.13 with RHEL 7.5 or LVDA 19.03 with RHEL 7.6 where the lock and power-off buttons are missing, as shown in here:

 

https://access.redhat.com/discussions/4013971

 

On a non-LVDA RHEL 7.5/7.6 gnome session ( e.g. directly on my laptop ),  the lock button can be made to appear and disappear via dconf-editor's ( org/gnome/desktop/lockdown/disable-lock-screen ) setting.

 

Just thought it may be something specific that LVDA does to the dconf settings ??

 

Might it have something to do with specifying a dedicated VDA session ?? ( e.g. CTX_XDL_VDI_MODE = Y ) ??

For example, in dconf-editor, I can see that "disable user switching" is turned on within in LVDA VDI session, but is turned off in my own laptop.

 

Link to comment

3 answers to this question

Recommended Posts

I can't reproduce this issue in normal session mode,  the lock buttons will be disable if you are in anonymous session mode, so please check if you are in anonymous session mode. For more gnome setting details, please refer to the shell file LVDA uses to launch session: /opt/Citrix/VDA/bin/ctxsession.sh. Far more help, turn to citrix support, pls.

Link to comment
18 minutes ago, Jigao Huang said:

I can't reproduce this issue in normal session mode,  the lock buttons will be disable if you are in anonymous session mode, so please check if you are in anonymous session mode. For more gnome setting details, please refer to the shell file LVDA uses to launch session: /opt/Citrix/VDA/bin/ctxsession.sh. Far more help, turn to citrix support, pls.

 

OK .. I will have a look at that shell script and see what I can find.

 

I am not in anonymous session mode .. in that:

 

1) I do not have the environment variable CITRIX_ANONYMOUS defined that I can see when I start an xterminal within the LVDA

2) I am authenticated via sssd_ad

 

My userid ( $id in bash ) in the LVDA is my corporate LAN id. Also, checking what the script does and what I get from gconf-settings-2 (Gnome2)  and gsettings ( Gnome3 ).

Looking at the Gnome2 section of the script, which does this:

 

    # For anonymous session
    if [ "$CITRIX_ANONYMOUS" ]
    then
        # Disable the lock screen button/menu/shortcut
        /usr/bin/gconftool-2 --set /apps/panel/global/disable_lock_screen --type boolean true
        /usr/bin/gconftool-2 --set /desktop/gnome/lockdown/disable_lock_screen --type boolean true
        /usr/bin/gconftool-2 --type string --set /apps/gnome_settings_daemon/keybindings/screensaver ''
        # Disable activating screensaver when idle
        /usr/bin/gconftool-2 --set /apps/gnome-screensaver/idle_activation_enabled --type boolean false
    fi

 

I can confirm that none of these are set:

 

[kjss@aallxppdc001 ~]$ /usr/bin/gconftool-2 --get /apps/panel/global/disable_lock_screen
No value set for `/apps/panel/global/disable_lock_screen'

[kjss@aallxppdc001 ~]$ /usr/bin/gconftool-2 --get /desktop/gnome/lockdown/disable_lock_screen
false

[kjss@aallxppdc001 ~]$ /usr/bin/gconftool-2 --get /apps/gnome_settings_daemon/keybindings/screensaver
No value set for `/apps/gnome_settings_daemon/keybindings/screensaver'

 

.. which confirms that I am not in an anonymous session.

 

 

Just to make sure, looking at the Gnome3 section of the script, which does this:

 

    # For anonymous session
    if [ "$CITRIX_ANONYMOUS" ]
    then
       # Disable lock screen button/menu/shortcut
       /usr/bin/gsettings set org.gnome.desktop.lockdown disable-lock-screen true
       /usr/bin/gsettings set org.gnome.settings-daemon.plugins.media-keys screensaver "[]"
       # Disable activating screensaver when idle
       /usr/bin/gsettings set org.gnome.desktop.session idle-delay 0
    fi

I can confirm that again none of these are set / modified:

 

[kjss@aallxppdc001 ~]$ gsettings get org.gnome.desktop.lockdown disable-lock-screen
false

[kjss@aallxppdc001 ~]$ gsettings get org.gnome.settings-daemon.plugins.media-keys screensaver
'<Super>l'

 

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...