Jump to content
Welcome to our new Citrix community!
  • 0

USB CD-ROM not being displayed in My Computer, shows detected in Device Manager


Michael DiPoffi1709160796

Question

Hey Everybody,

 

I'm encountering a weird issue with our USB CD-ROM drives (LG GP65NB60). I have one connected to our Dell WYSE 3040 Thin Client running ThinOS version 8.5_017 and when I log into a Windows 7 SP1 x64 virtual machine, the CD-ROM won't display in My Computer but the device will show installed in device manager with no errors. If I proceed to unplug the CD-ROM and plug it back in, it will then show up (I can also kill and then restart the explorer.exe process to make it show up). In the event logs it looks like it's installing the driver successfully and when I insert a CD everything works fine.

 

Here is the event log entry for the driver install:

"Driver Management concluded the process to install driver FileRepository\cdrom.inf_amd64_neutral_0b3d0d1942ab684b\cdrom.inf for Device Instance ID USBSTOR\CDROM&VEN_HL-DT-ST&PROD_DVDRAM_GP65NB60&REV_PF00\M02ICD93418_________&0 with the following status: 0x0." 

 

To get around this I've temporarily created a task in Task Scheduler which will run a batch script to kill and re-open explorer.exe based on the eventlog entry above. Is there something I'm missing to get this to display properly in My Computer? I don't like the idea of having to kill explorer.exe or having our end-users re-plugging the device in order for this to show up.

 

Thank you for any help you can throw my way, I'm stumped at this point..

Link to comment

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...