Jump to content
Welcome to our new Citrix community!
  • 1

Unable to boot vDisk in standard mode


Kasper Johansen1709159522

Question

Hi,

 

I am facing a strange and rather frustrating issue here.

 

Info about my current setup:

 

Hyper-V 2019 (Running since december 2018 without any issues)

PVS 1811 (upgraded to 1903) on Windows Server 2019

Target Devices are Gen2 (UEFI ) only, for now running either Windows Server 2016 og Windows 10 v1809

 

A couple of days ago I upgraded my PVS server to the latest version, v1903. After the upgrade everything was running fine for about a day or so, after that I started experiencing issues when booting target devices on vDisks in standard mode. I can boot any target device on any vDisk in private mode, however the same target device are unable to boot on the vDisk if it's in standard mode.

 

Right now I am out of ideas. I have been working with PVS for a long time, and I have never seen this kind of issue.

 

What I have tried so far:

 

  • Replaced the physical hard drive where the vDisks are located in Hyper-V, the drive was failing so I had to replace it
  • Downgraded the PVS server to 1811, also the target device software
  • Tried different filesystems, NTFS and ReFS
  • Tried booting Gen1 target devices, to rule out UEFI
  • Moved the PVS server and target device to a network without VLAN tagging (Both PVS server and target device is on the same network, no routing or firewall)
  • Disable antivirus (Windows Defender) and the windows firewall on the PVS server
  • Tested both ISO boot and BDM boot (I have been using BDM for the last couple of years)

 

I have enabled verbose mode in both the bootstrap and the BIOS bootstrap. When the target device boots on the vDisk in standard mode, it picks up the UEFI boot info and which vDisk to boot from, and from there on, it just sits there and never boots or never times out. I have had a target device sit for around 1 hour and 30 minutes, with no change.

 

I have attached a couple of screenshots of the boot process and where the target device hangs. Right now both the target device and the PVS server is back on PVS 1811.Boot-Info01.thumb.jpg.c0c4501db547ac26a5761196062a0dc6.jpgBoot-Info02.thumb.jpg.3a933d48a1c915a3bc02996b10b00b96.jpg

Link to comment

11 answers to this question

Recommended Posts

Hi, during the upgrade, did you also update the VDA software to 1903? From 1811 or earlier?

If so can you uninstall the VDA completely, reinstall and ensure you do not install MCS IO feature.

 

MCSIO in VDA 1903 installer would only be listed under features if you select "Create a master MCS image" on the environment step.

If an early VDA version was installed first however, MCSIO would have been included by default, and the component upgraded when you upgraded the VDA to 1903.

MCSIO version in VDA 1903 does should not be installed alongside PVS target device software.

Link to comment

Hi, great so a clean install.

Does it boot if you select different write cache types? Presumably you are using cache in ram with overflow on failure? What about Cache on HDD, Cache in Ram (assuming you can assign sufficient ram to target), cache on server?

From the screenshots it seems to be hanging just before the stage where it finds the locally attached disk, and confirms the cache type 

Link to comment

I have the Same Issue.

When i upgrade to VDA 1903, the PVS Targed will not boot.

I have try with PVS Traged Device Driver 1811, but same Issue.

Image boot correct in Maintance Mode, but will not boot in Standard Mode.

Cache is RAM with Overflow on Hard Disk.

 

I Will try tomorrow the uninstall of VDA an install VDA 1903 fresh again without the MCSIO Option.

I hope this will help.

 

Link to comment
20 minutes ago, Kasper Johansen1709159522 said:

Hi,

 

I can now confirm that it was the MCSIO driver that caused the issue. I have now deployed both Windows Server 2016 and 2019 target devices and they boot in standard mode with no issues.

 

Thanks kelanr for pointing me in the right direction.

 

i can also confirm that. After reinstall VDA1903 without MCSIO, the Targed boot with Standard Image.

Thanks for the resolution.

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...