Jump to content
Welcome to our new Citrix community!

Load Balancing RD 2016 connection brokers

Recommended Posts


I'm trying to load balancing my rds connection brokers services with my netscaler vpx 12 (just my connection brokers).


I tried all the solutions: lb vserver with rdp protocole, with tcp protocole and tried to use the same settings on my service group vserver (tcp 3389 or rdp 3389).

When I'm connecting to my web portal and clic on an application, a connection windows appaears and nothing more...

I have 2 connection brokers (rd web is also installed on each) and 3 rds servers in my collection.


When I bypass the netscaler using the DNS round robin method, it works.


I tried to read the statistics: my load balancing vserver has hits every time I try to launch an application but my service group never show any statistic, like the request never joins my back end brokers.

I obsiouvly tried with only one broker....Same results....


I saw on my client event id 1024 => ClientActiveX RDP tries to connect to server  (brokers.xxxxxx.xxxx), corresponding to my broker's VIP.

Then, event id 1105 => The multitransport connection has been lost (or cut).

Then event id 226 (cf screenshot attached).


Thank you for your help !









Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...