Jump to content
Welcome to our new Citrix community!

Change Timezone VPX 12 GUI

Recommended Posts


I'm unable to change my timezone on my fresh installed vpx

I tried in command line, save my conf and reboot and the netscaler is still at coordinateduniversaltime.


 I see differences in time beetwen the system and the logs in the dashboard, which are at the good time.


Thank you for your help,







Link to comment
Share on other sites

We also got this error. We tried this on fresh installation of NetScaler version 12.1-51.19 and 12.1-50.28 (through GUI and CLI) . It also look like it's not on every zone.

When we changed it to GMT+08:00-HKT-Asia/Hong_kong we didn't receive this eror. So this problem doesn't occurs on every timezone. We tried almost every GMT+01:00, but noe was accepted.

Link to comment
Share on other sites

On 12.1, you will likely need to use the following method to fix the timezone via cli:

set ns param -timezone <timezone value>

Example:  set ns param -timezone GMT-05:00-EST-America/New_York

you can use this to find likely timezone value string

help set ns param | grep <city> -i

A full reboot is usually required.

Then you can use shell; date YYYYMMDDhhmm to set clock; then work on your NTP settings.


Depending on the build, the alternate methods of changing the timezone don't always work:

GUI Wizard

GUI: System > Settings > Set Timezone

CLI: config ns



Link to comment
Share on other sites

What time zone or city are you looking for; the time zone strings won't reflect Daylight saving time, but the timezone will adjust for it.  So look up the standard timezone offset (no daylight saving adjustment) for your location's nearest major city for best results in the cli parameters.


For Example setting to New York EST, will still handle EDT adjustments as well.

set ns param -timezone GMT-05:00-EST-America/New_York


Complete list of timezone strings are listed in the command reference, if help isn't working for you:  https://developer-docs.citrix.com/projects/netscaler-command-reference/en/latest/ns/ns-param/ns-param/



Edited by Rhonda Rowland
added clarifying note.
Link to comment
Share on other sites

Testing on vsersion 12.149.23, this works.

set ns param -timezone GMT+01:00-CET-Europe/Amsterdam

It is a CLI command and not shell command.


set ns param -timezone GMT+01:00-CET-Europe

Then doing a <tab> completion shows amsterdam in the list.


So if that still doesn't work, it may be a version specific bug. But setting to any GMT+01:00-CET location should work for the same behavior.

Instead of tab completing try the following as well:

help set na param | grep "GMT+01:00-CET-Europe/" -i

And see if you get a more complete list of timezone strings.


the invalid argument is weird in your original screenshot as everything looks fine, unless you are having an issue with En-dashes vs Em-dashes; but it doesn't look like it.


Link to comment
Share on other sites

Hi Rhonda,


Thx for your support....  


I also deployed version 12.1 492.23 and with this version I have no problem changing the timezone.... (even with the GUI) 

t really looks like a "version specific bug". So this problem exists in the two latest versions of the Netscaler OVF (12.1-51.19 and 12.1-50.28).



Link to comment
Share on other sites

  • 2 weeks later...

Hi Guys

Amsterdam (and Copenhagen) have been placed in GMT+02:00-CEST.


GMT+02:00-CEST-Europe/Amsterdam  GMT+02:00-CEST-Europe/Copenhagen GMT+02:00-CEST-Europe/Paris      GMT+02:00-CEST-Europe/Tirane
GMT+02:00-CEST-Europe/Andorra    GMT+02:00-CEST-Europe/Gibraltar  GMT+02:00-CEST-Europe/Podgorica  GMT+02:00-CEST-Europe/Vaduz
GMT+02:00-CEST-Europe/Belgrade   GMT+02:00-CEST-Europe/Ljubljana  GMT+02:00-CEST-Europe/Prague     GMT+02:00-CEST-Europe/Vatican
GMT+02:00-CEST-Europe/Berlin     GMT+02:00-CEST-Europe/Luxembourg GMT+02:00-CEST-Europe/Rome       GMT+02:00-CEST-Europe/Vienna
GMT+02:00-CEST-Europe/Bratislava GMT+02:00-CEST-Europe/Madrid     GMT+02:00-CEST-Europe/San_Marino GMT+02:00-CEST-Europe/Warsaw
GMT+02:00-CEST-Europe/Brussels   GMT+02:00-CEST-Europe/Malta      GMT+02:00-CEST-Europe/Sarajevo   GMT+02:00-CEST-Europe/Zagreb
GMT+02:00-CEST-Europe/Budapest   GMT+02:00-CEST-Europe/Monaco     GMT+02:00-CEST-Europe/Skopje     GMT+02:00-CEST-Europe/Zurich
GMT+02:00-CEST-Europe/Busingen   GMT+02:00-CEST-Europe/Oslo       GMT+02:00-CEST-Europe/Stockholm

Special kind of humor, if you ask me. However, this command works: set ns param -timezone GMT+02:00-CEST-Europe/Copenhagen


Link to comment
Share on other sites

Hello Fellow Netscalers

We have the same issu with NS12.1 51.19.nc.

The Dokumentation seems off (https://developer-docs.citrix.com/projects/netscaler-command-reference/en/latest/ns/ns-param/ns-param/)

It no longer is GMT+01:00-CET-Europe\*. The entries now all run under GMT+02:00-CEST-Europe\*


---> because its summertime =)


The GUI seems to be confused by this, but the command set ns param -timezone GMT+01:00-CEST-Europe/Berlin still works

So just ignore GUI and set it with CLI. 





Link to comment
Share on other sites

One thing I saw recently is that the GUI will rename EST to EDT and CET to CEST and adjust the "diplay" value to reflect summer time so -05:00 become -04:00 etc. But the CLI uses the raw timezone GMT-05:00 and doesn't include the summer time offsets, though once selected it will use the correct daylight saving offset if appropriate.


There still might be a  bug in certain versions. But from CLI use the raw timezone without offset for your location and it will include it if necessary.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...