Jump to content
Welcome to our new Citrix community!

Issue access via HTTP with NetScaler Gateway


Moussa ML

Recommended Posts

Hello all,

 

I have an issue with access via NetScaler Gateway this is the difference between access directly and access with NetScaler GW:

 

 

Access to service with NetScaler Gateway 

curl exemple.city.com -v

* Rebuilt URL to: exemple.city.com
*   Trying 10.10.108.12...
* TCP_NODELAY set
* Connected to exemple.city.com (10.10.108.12) port 80 (#0)
> GET / HTTP/1.1
> Host: exemple.city.com
> User-Agent: curl/7.50.3
> Accept: */*
>
* HTTP 1.0, assume close after body
< HTTP/1.0 400
< Content-Type: text/html
<
<html><head><title>Error</title></head><body>
<h2>ERROR: </h2>
<br>
* Curl_http_done: called premature == 0
* Closing connection 0
</body></html>

 

 

Access directly without NetScaler Gateway

 

curl exemple.city.com -v

* Rebuilt URL to: exemple.city.com
*   Trying 10.10.108.12...
* TCP_NODELAY set
* Connected to exemple.city.com (10.10.108.12) port 80 (#0)
> GET / HTTP/1.1
> Host: exemple.city.com
> User-Agent: curl/7.50.3
> Accept: */*
 

< HTTP/1.1 401
< Server: nginx/1.11.9
< Date: Thu, 28 Mar 2019 13:07:46 GMT
< Content-Type: text/plain;charset=UTF-8
< Transfer-Encoding: chunked
< Connection: keep-alive
< WWW-Authenticate: Basic realm="TeamCity"
< Cache-Control: no-store
<
Authentication required
* Curl_http_done: called premature == 0
* Connection #0 to host  exemple.city.com left intact
To login manually go to "/login.html" pag

 

 

 

Best Regards,

Moise

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...