Jump to content
Welcome to our new Citrix community!
  • 0

HTML5 Workspace saying Cannot Complete Your Request when trying to access.


Jesse Leonard1709160747

Question

I scrapped my old setup and spun up a new server since the old one was not and full production and over time had developed issues for some reason. All health checks from Director are good. Workspace for Windows works fine. However when connecting with HTML5 workspace it pops right up with "Cannot complete your request." Every time this happens the Storefront server logs and error in the event viewer:

 

Failed to run discovery
Citrix.Web.DeliveryServicesProxy.ConfigLoader.DiscoveryServiceException, ReceiverWebConfigLoader, Version=3.12.0.0, Culture=neutral, PublicKeyToken=null
An error occurred while contacting the Discovery Service
   at Citrix.Web.DeliveryServicesProxy.ConfigLoader.Discovery.AppendConfigurationFromDiscoveryService(WebReceiverConfigSection section)
   at Citrix.Web.DeliveryServicesProxy.ConfigLoader.Discovery.RunDiscovery(WebReceiverConfigSection configSection)
   at Citrix.Web.Proxy.Filters.DiscoveryComplete.OnAuthorization(AuthorizationContext filterContext)

System.Net.WebException, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
The underlying connection was closed: An unexpected error occurred on a send.
Url: https://127.0.0.1/Citrix/Store/discovery
ExceptionStatus: SendFailure
   at System.Net.HttpWebRequest.GetResponse()
   at Citrix.DeliveryServicesClients.Utilities.HttpHelpers.ReceiveResponse(HttpWebRequest req)
   at Citrix.DeliveryServicesClients.Utilities.HttpHelpers.ReceiveResponse(String url, String token, HttpRequestParameters options, Object requestData, CookieContainer cookieContainer, Boolean overrideLoopback)
   at Citrix.DeliveryServicesClients.Discovery.RequestHandler.DiscoveryHttpRequestHandler.GetDocument(String url)
   at Citrix.DeliveryServicesClients.Discovery.DiscoveryClient.GetDocument(String url)
   at Citrix.Web.DeliveryServicesProxy.ConfigLoader.Discovery.AppendConfigurationFromDiscoveryService(WebReceiverConfigSection section)

System.IO.IOException, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host.
   at System.Net.Sockets.NetworkStream.Read(Byte[] buffer, Int32 offset, Int32 size)
   at System.Net.FixedSizeReader.ReadPacket(Byte[] buffer, Int32 offset, Int32 count)
   at System.Net.Security.SslState.StartReceiveBlob(Byte[] buffer, AsyncProtocolRequest asyncRequest)
   at System.Net.Security.SslState.CheckCompletionBeforeNextReceive(ProtocolToken message, AsyncProtocolRequest asyncRequest)
   at System.Net.Security.SslState.ForceAuthentication(Boolean receiveFirst, Byte[] buffer, AsyncProtocolRequest asyncRequest)
   at System.Net.Security.SslState.ProcessAuthentication(LazyAsyncResult lazyResult)
   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
   at System.Net.TlsStream.ProcessAuthentication(LazyAsyncResult result)
   at System.Net.TlsStream.Write(Byte[] buffer, Int32 offset, Int32 size)
   at System.Net.ConnectStream.WriteHeaders(Boolean async)

System.Net.Sockets.SocketException, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
An existing connection was forcibly closed by the remote host
   at System.Net.Sockets.NetworkStream.Read(Byte[] buffer, Int32 offset, Int32 size)

I ran through the troubleshooting from the Citrix page for the "Cannot complete your request" error. Everything was good.

 

Citrix Xenapp 7.15 CU3, newest Windows and HTML5 Workspace. I am using HTTPS to connect to Storefront.

 

The only other odd thing I have is a Powershell warning about an x509 cert in event viewer. I believe this is easily fixed by trusting a cert from one of the Citrix folders.

 

One last thing, if anyone can point to a good article for setting up Netscaler VPX 50 for Xenapp I would be grateful!

Link to comment

3 answers to this question

Recommended Posts

Carl, I see you are watching this. :-) You solved it! I'm not sure why, I have a cert bound to HTTPS, but I followed your advice to change the loopback URL to OnUsingHTTP. Storefront comes up and works great.

 

For Netscaler am I safe to just follow your ICA proxy guide? There's so much involved with it and we have very basic licensing. I know when I tried following the guided setup it yelled at me a lot about licensing on some stuff. It's not very clear.

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...