Jump to content
Welcome to our new Citrix community!
  • 1

Problem with Citrix Workspace for Windows and multiple monitors

Calvin Grucelski


Hi, all.


I've searched through the various support forums here and on other sites and have found that other users have experienced similar problems to mine, but I haven't found anyone with the same exact problem. I believe I read somewhere that using multiple monitors with different resolutions is not officially supported by Citrix, but I'm hoping someone has a work-around, as nothing I have found seems to solve my issue and the Citrix Workspace application is mostly useless for me at this point. 


I have a Microsoft Surface Book running Windows 10 Pro with a native resolution of 3000x2000. In the display settings, I have the 'Change size of text, apps and other items' parameter within the 'Scale and Layout' section in the Display properties set to 200% for the primary display. I use a Surface Dock, which is connected to a full-size keyboard and mouse, portal SSD drive and two identical Viewsonic external LCD monitors.


Both monitors are running at a resolution of 1920x1080. In the display settings, I have the 'Change size of text, apps and other items' parameter within the 'Scale and Layout' section in the Display properties set to 100% for these two secondary displays. I have read elsewhere that one of the suggestions is to set the resolution of all monitors the same, but I do NOT want to change the native resolution on the Surface Book to match the secondary monitors and replacing those monitors simply isn't an option. 


Our company runs several applications within the Citrix environment, so in addition to my normal desktop applications, there are several programs that I need to run from either a direct Citrix shortcut, or via Citrix remote desktop, which I believe is running Windows 7. The stand-alone Citrix applications that I run via direct shortcut stay windowed and running only on one monitor, as desired and expected. However, the remote desktop session always opens in full screen mode and spans across all three monitors, which is NOT what I want.


If I press the Shift-F2 keys, the Citrix desktop switches to windowed mode, allowing me to resize and move the window to just one monitor, but the desktop is messed up and unusable, presumably due to the difference in resolution and/or DPI. The start menu bar isn't positioned correctly and the mouse position is wrong, meaning the active area is 2-3 inches away from where I click. I usually have to force close the window in order to exit, as there's no way to click on the 'Start' menu. See screenshot1 attached. 


I am running what I believe is the latest version of the Citrix Workspace app, Within the advanced preferences of the Citrix Workspace application, there is a 'High DPI' section with three possible settings (Yes, No, Let operating system decide). I have tried all three options with no success. See screenshot2 attached. I would be grateful for any ideas or suggestions for potential solutions. 


Thanks in advance!




Link to comment

11 answers to this question

Recommended Posts

  • 2

I got the 2 Screens working. Now the Problem ist that i have a 4k Monitor and in remote Desktop i cannot scale the windows screen. I am seeing everything very very small...



This solution worked for me:

Follow below steps to fix the issue,

Logoff all ICA session and exit Receiver

Navigate to C:\Program Files (x86)\Citrix\ICA Client\

Locate wfica32.exe and right-click it, choose Properties -> Compatibility-> Change High DPI Settings - Check the Override high DPI scaling behavior and ensure that the Application option is selected.

Click OK

Repeat step 3 for wfcrun32.exe

  • Like 2
Link to comment
  • 0

Setup the sleep settings on your Surface Book so that, when you close the lid/cover, the computer does NOT go to sleep. Then, close the lid/cover and Windows 10 should automatically reconfigure to use only the two external displays.


Next, connect to your Cloud Desktop and then switch to Window mode. Once in Window mode, stretch the edges of the window so that you are spanning it across both external monitors and have almost full coverage of both monitors. Finally, switch to full screen mode and then logoff (don't disconnect) your Cloud Desktop session.


Once the session ends, open your Surface Book's cover again, wait for Windows to reconfigure the displays so that all three are working again, then reconnect to your Cloud Desktop. You should find that your Cloud Desktop now spans only the (2) external displays.

Link to comment
  • 0

Hi, all.


Thanks to Bart Jacobs and Alozzy for responding to my original question from earlier this year. Sorry for the delay in following up on this post.


Bart Jacobs - I do not know if the published desktop is configured to always launch in full screen, but I have to assume it is, based upon the fact that it is doing so. How or where would I check this? 

Alozzy - I have tried your suggested solution, but unfortunately it did not work for me. I was hopeful it would, as this is the first suggestion I have seen online that addresses the idea of essentially disabling the default display by closing the lid of the Surface Book. Unfortunatley, the behavior of the remote desktop is still the same... it always spans all three monitors as soon as I enable the Surface Book display. 


The only solution I have found that is actually manageable and usable is to start the Citrix Workspace app and connect to the remote desktop session, then once the desktop loads, press the SHIFT-F2 key combination, which places the desktop into windowed mode, which is unusable due to the resolution issue noted in my original post. 


One of my co-workers pointed out that once the desktop has finished loading and is running in windowed mode, I can right click on the window title bar at the top of the screen and select the 'Resize Session' option. I then select 'Custom' from the Desktop Size list and enter the resolution of the monitor I want to run the desktop on, in my case 1920x1080.


I can then drag this window to one of my external monitors and click the 'full screen' box in the upper right and it fits my external monitor screen perfectly, but still allows me to access my local desktop and task bar on all three monitors. The only drawback is that there appears to be no way to save these settings between sessions. 


I've searched all over online and cannot find any references to saving the Resize Session option and the Desktop Size and Requested Color Quality settings within. I was hoping there might be a configuration file somewhere or a registry entry that could be  edited to save these settings, but it does not appear that there are. 


Is anyone aware of a way to save the Resize Session option and custom Desktop Size settings? 



Link to comment
  • 0



The problem mentioned about the screen opening in the 3 monitors i always had but always managed to press "SHIFT+F2", drag the desktop to the main window and then double click on the grey zone ate the top of the Citrix desktop to automatically resize it.


It always worked fine maintaining the desktop in the main window.


The problem now is that it started, after a while, to stretch to the 3 screens forcing me to press "SHIFT+F2" 2 or 3 times until* i can drag it again to the main screen and repeat the initial steps. *(Once it does this it makes it 2 or 3 times again until it stops for a while..)


It seems to be a different issue but...

Link to comment
  • 0

I was having a similar problem to some of you all. My Citrix workspaces were not behaving properly when i had them connected to two other monitors from my laptop. I was seeing a large black margin on the left and my cursor was offset by a few inches. The fix with closing my laptop and having the monitors only worked for me however i found a way to use all everything as it should be and thought i would share after seeing this thread. The fix that i found out was not that the resolution was the issue as all of my displays had the same resolution but the issue was still occurring, however i did noticed that on the laptop the text size and scaling was set to 125% and the other monitors had it set to 100%. I changed the laptops scaling to reflect the other monitors at 100% and seemed to correct the issues that my specific case was seeing with the black margin and the offset cursor. Hopefully this helps some.

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...