Jump to content
Welcome to our new Citrix community!
  • 0

Error while logging into storefront. Could not complete your request.


Steven Burke

Question

Hi guys,

 

I have installed the latest version of Citrix via a trial because i am trying to get more known with the newest version of Citrix.

The whole installation went fine but some reason i keep getting the error Could no complete your request.

 

My configuration is super basic because i just installed all of the Citrix roles on 1 server.

Set up a AD on another VM and  i have 1 other vm as TS.

All in the same virtual network ofcourse.

For the storefont server i used a self signed certificate which i created in IIS.

I am not using a Gateway/Loadbalancer.

 

 

 

In the eventviewer i see the following error.

 

An unexpected response waas received during the authentication process.

Citrix.DeliveryServicesClients.Authentication.Exceptions.ExplicitAuthenticationFailure,

Citrix.DeliveryServicesClients.Authentication, Version = 3.16.0.0, Culture= Neutral, PublicKeyToken=null.

General Authentication Failure

ExplicitReuslt.State 5

AuthenticationControllerRequestUrl:

https://c1.citrixtst.local/Citrix/StoreWeb/ExplicitAuth/LoginAttempt

ActionType:LoginAttempt at Citrix.Web.AuthControllers.Controllers.ExplicitAuthController.GetExplicitAuthResult(ActionType type,Dictionary'2 postParams).

 

I already tried the solutions that are mentioned here: https://support.citrix.com/article/CTX207162

but unfortunately without any positive result.

 

 

 

 

 

 

Citrix.PNG

Citrix2.PNG

Link to comment

5 answers to this question

Recommended Posts

I found the following error in the eventviewer log on the storefront/delivery controller server.


===========================================

 

An unexpected network response was received during the authentication process. WebException Status: ProtocolError.
System.Net.WebException, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
The remote server returned an error: (500) Internal Server Error.
Url: https://127.0.0.1/Citrix/tryAuth/CitrixFederation/Authenticate
ExceptionStatus: ProtocolError
ResponseStatus: InternalServerError
AuthenticationControllerRequestUrl: https://c1.citrixtest.local/Citrix/tryWeb/DomainPassthroughAuth/Login
   at System.Net.HttpWebRequest.GetResponse()
   at Citrix.DeliveryServicesClients.Utilities.HttpHelpers.ReceiveResponse(HttpWebRequest req)
   at Citrix.DeliveryServicesClients.Authentication.TokenIssuingClient.RequestToken(String url, RequestToken requestToken, String primaryToken, String languages, CookieContainer cookieContainer, IEnumerable`1 acceptedResponseTypes, IDictionary`2 additionalHeaders)
   at Citrix.DeliveryServicesClients.Authentication.CitrixFederation.CitrixFederationAuthenticator.Authenticate(RequestTokenResponse generatedToken, IDictionary`2 extraHeaders)
   at Citrix.Web.AuthControllers.Controllers.FederatedAuthBaseController.AuthenticateInternal(CitrixFederationAuthenticator authenticator, RequestTokenResponse generatedToken)
   at Citrix.Web.AuthControllers.Controllers.FederatedAuthBaseController.Login(IClaimsPrincipal claimsPrincipal)
============================================

 

 

If i try going to the url Url: https://127.0.0.1/Citrix/tryAuth/CitrixFederation/Authenticate on the storefront server.

I get the following error.

 

Server Error in '/Citrix/tryAuth' Application.

The resource cannot be found.

Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable.  Please review the following URL and make sure that it is spelled correctly.

Requested URL: /Citrix/tryAuth/CitrixFederation/Authenticate

 

Link to comment

The problem has been solved.

After trying basicly everything within Storefront.

Getting the certificates signed by my own internal CA.

Playing with the loopback options + com settings ipv --> DNsport etc...

That did not help.

When i did a fresh install of Storefront on a different server and added connect it to the already exisiting delivery controller.

Everything worked fine with self signed  IIS certificates.

 

 

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...